BPVA 2.1 Installation Issues - Are new keys required?

Hi all

I currently have BPVA 2.0 installed. I previously had version 1.1, so my Key Manager shows my 1.1 and my 2.0 “upgrade” keys present in order for BPVA 2.0 to function.

I’ve recently installed 2.1 (however, I did not remove 2.0, but rather installed 2.1 to a different directory). When BPVA is launched it displays the Key Manager, which doesn’t initially show any of my keys. Instead, when I toggle the “all keys” option it shows my 2.0 key as “valid”, but will not let me continue with the BPVA 2.1 application. Instead after exiting the Key Manager a few times BPVA tells me that it will close.

I have tried removing and re-adding the 1.1 and 2.0 keys; BPVA 2.1 doesn’t seem to like the 1.1 key at all (it said something like it was already in use), and like above, the 2.0 key didn’t let me continue launching the BPVA 2.1 program. Thinking it may be a conflict between BPVA 2.0 and 2.1 I launched the Key Manager from within BPVA 2.0 and removed the keys. Then I went into BPVA 2.1 and added them. They added fine… but still wouldn’t let the program launch. Interestingly, when I went into BPVA 2.0 it seemed to find the keys added via my attempt with 2.1 just fine and I didn’t need to add them again.

Basically, I am unable to proceed with launching the 2.1 product at this point (but 2.0 continues to work). An earlier posting by someone else earlier this year reported a similar error message but was obviously not involving 2.1… and I don’t know if there was any resolution to this or not.

Please advise… I have about 40 people here, and I just know that someone will try the upgrade before I can stop them…


Hi Cameron,

The key for version 2.0 won’t work with version 2.1. In order to run version 2.1, you need to log into your customer account, and download the upgrade key. Here is the URL of our Customer Service Center where you can get your license key(s):

Best regards,

Hi Jick

Thanks for the info… that seemed to work for SOME machines.

However, others have had serious issues. These machines originally had BPVA 1.1, which was upgraded to 2.0 at some point. Then, to get to 2.1, I followed the instructions:
Uninstalled 2.0
Removed the keys
Installed 2.1
Added the 1.1 key; no error but didn’t show up in the Key Manager list
Tried to add the 2.0 and 2.1 keys - the Licence Viewer (not the BPVA Key Manager) said the 2.1 key was expired (and it was brand new!).
Got fed up, uninstalled 2.1
Reinstalled 2.0
Added the 1.1 key; no error but didn’t show up in the Key Manager list
Tried to add the 2.0 and 2.1 keys - got an error message that I was adding upgrade keys without the original one in place
Gave up entirely

So, now I have a block of machines that have no valid keys at all; the BPVA tool is totally unusable (regardless of version).

Can I suggest this: for keys where I’ve gone from 1.1 to 2.0 to 2.1, can you issue me a block of keys that are “just” 2.1 (i.e. not upgraded)? Or can you fix the problem with the Key Manager / Licence Viewer?

Or do I have to start from scratch and install 1.1 again and move from there? Not very practical, especially for machines where I am re-issuing / installing due to departed employees: to re-use those licences do I need to install the software three times?

Please advise… I’ve got about 15 people getting rather annoyed right about now.


Hello Cameron,

Thank you for your reply. You do not need to reinstall version 1.1. Please try the steps below for those machines that can’t upgrade:

  1. Remove %HOME%/.vplls (e.g. C:\Documents and Settings\Jick.vplls)

  2. Start BP-VA

  3. Import the key for version 1.1

  4. Import the key for version 2.1

Note: You do NOT need to import the key for version 2.0 throughout the whole process. Of course, if you are currently running version 2.0, you do not to remove the key either. All you need is to import the upgrade key (2.1) into the Key Manager.

Best regards,

Hi Jick

Thanks for the response. Unfortunately, it didn’t work.

On the PC that was having problems I deleted the .vplls folder under Documents and Settings (as well as one under Windows\System32). Then I ran the 2.1 installer again.

When I entered the 1.1 key it said it was imported successfully (though there was no way to make it appear in the list, even when I toggled Expired Keys and All Keys on).

When I entered the 2.1 key it said “You have imported an upgrade license key without importing the original license key. In order to perform the upgrade, please also import the original license key.” Trying again to import the 1.1 key had no effect.

As I mentioned before, when I ran the Licence Viewer in the \bin directory, it said that the 2.1 had expired. Do I need to download the keys again? And why is the tool refusing to import a valid 1.1 key (no errors, it just isn’t importing it!)?

Please advise… thanks

Hi Cameron,

Just sent you an Email. I would like to hold an online meeting with you to check this problem.

Best regards,

Hi Cameron,

Thank you for joining my meeting. As we have concluded, the problem is due to wrong data being stored in the file at %HOME-DIR%/.vpumlprops. Deleting it will solve the problem.

Best regards,

Thanks again.

And while you are at it: is there a chance of a Release Notes or README.TXT file being included in the installation? This would be the first sort of thing I would check re possible installation issues, etc. and would be handier as a quick reference to the changes in the release (I know that you have a web page for this, but it is often easier to bundle it rather than have the user search through your site for it).

Just a suggestion… thanks

Thanks Cameron, I’ll share your request with our team.