BPVA Update 2.0 times out


I am using Visual Architect Modeler Edition and I tried to run the updater (BPVA Update 2.0) for the first time.
It first said my updater was out of date. It downloaded a few kb and then suddenly stopped (no freeze or crash, just doing nothing). After a few retries I let it run in the background and after about two or three minutes it suddenly restarted downloading.

After this I checked for updates and it gave me a whole list of files to download. I clicked next and again the updater halted after a few kb. After about 10-20 minutes it displays:

BPVA Update was not able to download the following update file(s). Please try update the software with other update server.

I tried the other update server, with the same result. Also, excluding the file named above, did not lead to a positive result.

Could you give me any clue why the program won’t update?

Friendly regards, Johan

Hello Johan van der Lingen,

Thank you for your post. We’ll investigate the problem. Could you send me %BP-VA-Installation-DIR%/bin/vp.log and %BP-VA-Installation-DIR%/bin/vpupdate.log for identifying the problem? Thank you.

On another note, if you’re our customer and your maintenance is still valid, please consider advancing to BP-VA 2.1. You can download version 2.1 from your customer account

Best regards,

Thanks for your answer, Jick.

I sent you the logs by private message.

I wasn’t aware that version 2.1 existed, but now I have it installed. The updater reports that there are no updates at this time, but if I experience the same time-out problem in the future with version 2.1, I will post again.

Thanks, Johan van der Lingen.

If you experience the same problem again, feel free to let me know.

Best regards,

Hi Jick,

I am now using BPVA Update 2.1 and I’m having the same problem.

I will send you the vp.log and vpupdate.log by email.

best regards,


Hi Johan, I have received your Email. We will look into the problem as soon as possible. Thank you.

Have a nice weekend!