Can's start Visual Paradigm!


I installed on a Win xp Sp3 machine. When i run the VP Suite 5.0\bin\Visual Paradigm for UML 8.0.exe i get the following error message: “The JVM could not be started. The main method may have thrown an exception

getting the same error, something definitely broken.

Dear users,

Thank you for your message. Can you try the following steps and see is it working?

  1. download the attached file to the bin folder of VP Suite
  2. rename the debug.txt to debug.bat
  3. double click to execute debug.bat

Best regards,

still the same problem; running debug.bat didn’t help

Thanks, .bat file works!

if the problem continues, make a change in the archive, open with notepad and modify “-Xms256m -Xmx1024m” to " -Xms256m -Xmx512m", the problem is because don’t have the ram to work with the configuration… i hope to work…

thanks all for helping me to solve the same problem :slight_smile:

Thanks for your answer.
I had this problem in Windows server 2008 R2 and solved this with this answer.

Tanks a lot…


Thanks a lot. I made a Change in the Archive as said above and It works perfectly. Thank you .

I used bat file, but it worked only with “-Xms256m -Xmx512m”. I get

“Cannot read Product and Edition
[Sat May 12 11:54:25 GMT+06:00 2012]:
Edition [VP-UML PE]: 8.0 (sp1_201010
Not running DB-VA or VP-UML using RV”

all the time.

With “-Xms256m -Xmx1024m” get error:

Error occurred during initialization of VM
Could not reserve enough space for object heap
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Help me please

May I know how many physical memory you have on your machine? And what OS you are using?

Best regards,
Rain Wong