Can't rename column in Entity (ERD Diagramm)

I have an Entity.
It has several columns.
One of them (it’s name is ‘number’) I can’t rename.
I mean I can give it any name except ‘teamNumber’. So it is :(.
Maybe someone could help?

Dear Terix,

Sorry but I do not understand. I tried renaming a column named as ‘number’ into ‘teamNumber’, and it works fine. Here is what I did:

Could you comment on this? Thanks a lot.

Best regards,

Jick, Terix:

I have noticed this behavior when there is a relationship between two tables in an ERD, say table A and table B, when table A has an attribute called somename and I want to rename an attribute in table B to the same name, i.e. to somename . VP-UML ignores the rename (although it is not inconsistent as the tables are separate tables). The only fix I have found is to break the relation (if there are several you have to break all of them) modify the attribute name in table B, and then add the relationship back in from A to B.

I don’t remember exactly if this happened with 1-1 or 1-N relationships from A to B. I am sure it was not an N:M relationship.

Hi Jorge,

Long time no see. How are you?

I tried several combinations - with different kinds of relationship, and different state of column (PK, FK), but I am unable to produce the problem. Do you have the project file or the steps that can let us produce the problem?

Best regards,