Code generated by VP doesn't run properly

Hi, there,

I always get following exceptions when I run files generated for JPA by VP to create tables, this only happen in Many to many relationship with composited key. no link table.

java.lang.ArrayIndexOutOfBoundsException: 5
at org.hibernate.persister.entity.AbstractEntityPersister.initSubclassPropertyAliasesMap(
at org.hibernate.persister.entity.SingleTableEntityPersister.(
at org.hibernate.persister.PersisterFactory.createClassPersister(
at org.hibernate.impl.SessionFactoryImpl.(
at org.hibernate.cfg.Configuration.buildSessionFactory(
at org.hibernate.cfg.AnnotationConfiguration.buildSessionFactory(
at org.orm.util.ORMSessionFactory.(
at org.orm.util.ThreadBaseSessionController.(
at org.orm.PersistentManager.(
at com.dynadocs.vfs.SecureChannelPersistentManager.(
at com.dynadocs.vfs.SecureChannelPersistentManager.instance(
at ormsamples.CreateSecureChannelDatabaseSchema.main(

But the DDL script works fine. only I got those errors when I run code generated by VP.

Looking forward to your response .
thank you in advance.


Hello Wen,

Thank you for your message. Would you mind send me your project file also the testing program (which can generate this problem) to have a look? You can send the files to in case you don’t want to put it to this forum.

Look forward to hear from you.

Best regards,