Code generation and "orm..." packages

I use SDE 5.1 in NetBeans.

Please tell me how to do some things.

  1. I got ERD from database, now i’m want to generate hibernate code. That’s fine, but! Lots of files placed under packages with names started with “orm”. How to change this? I want my package structure follow “com.companyname” notation, but not “ormmapping.com.companyname” and no more packages in the root except one.

  2. My comment should be in my native language, but after code generation all my native simbols are squares. I try everything in the Application settings of SDE, but the result all time is the same. In database all fine.

  3. How to change TAB to spaces in generated code? The settings didn’t work. I use ORM->Wizards to generate code and DB.

Sorry my bad English. :oops:

Hi Enco,

Thanks for your post. For the issues:

  1. Actually the “ormmapping” folder is solely a directory storing your ORM mapping files, it does not affect your package structure of objects. It can avoid mixing ORM mapping files and source code in the output directory.

  2. I’ve passed this issue to our engineers to follow-up. Once there is any feedback, I’ll come back to you.

  3. I’m sorry that changing TAB to spaces is not supported, but we will consider it.

Best regards,
Lilian Wong

P.S. Wish you a Merry Christmas and Happy New Year!

Hi Enco,

I would like to notify you that the non-English comment problem in ORM code has been fixed, please update your software to latest patch (sp1_20100106a or later). More details about update to latest patch can be found from:

Please let me know if there is anything we can do to help. Wish you a happy new year!

Best regards,
Lilian Wong