Continual Crashing in Community Edition in Eclipse 3.3.0

I just downloaded the SDE Community Edition to give this program a try. It installed okay, but when I go to New Diagram>New Class Diagram, Eclipse crashes without any error messages. The VP log file says nothing but:

Start Smart Development Environment Community Edition for Eclipse [SDE CE-EC]: 4.0 (sp2_20070612)

The error log (hs_err_pid3328.log) indicates:

An unexpected error has been detected by Java Runtime Environment:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d0351af, pid=3328, tid=2548

VM Arguments:
jvm_args: -Xms40m -Xmx512m -XX:MaxPermSize=256m -XXermSize=64m
java_command:
Launcher Type: generic

I have to say I’m a bit underwhelmed since this can’t even get off the ground after a clean install of both Eclipse and SDE. Can this be solved relatively quickly?

Thanks

Hi rollingsj,

Are you running Eclipse with JDK 1.6? Currently, SDE-EC has not been tested with JDK 1.6. This may be the cause of problem.

If you are not running JDK 1.6, please send me your Eclipse configuration details. You can find them from the About dialog box of the Eclipse.

Best regards,
Jick

Hi, guys

I got almost the same problems. SDE for Eclipse crashes while trying to create e.G. a class or sequence diagram from an existing Java class.

I could solve a problem, which occured when trying to just create a new sequence diagram, in changing one argument in the eclipse.ini from:
-XX:MaxPermSize=128m
to:
-XX:MaxPermSize=256m

But this didn’t solve the before mentioned problem.
I know, that VP SDE was not yet tested with Eclipse 3.3 and Java 1.6, but it is essential for me to get things running.
Hopefully some of you guys know what to do?!
I would appreciate every good news. :wink:
Thanks in advance

Greetings
Joss

Hi Joss,

Thank you for your post.

Please provide me with your Eclipse configuration details. You can find it from the About dialog box of Eclipse.

Please also provide me with the steps to reproduce the problem. Thank you.

Best regards,
Jick

Hi, Jick

In the following are the steps to reproduce the error. Here we go:
-start Eclipse
-start SDE EC-CE
-click on the workspace tab
-open any package you have
-look for an *.java file
-right click on *.java file -> New -> New Diagram -> New Sequencediagram
-voila “crash”

You’ll get no error message, at least my Eclipse did not throw any.
The Eclipse configuration can be found in the attachment.

Greetings
Joss
Eclipse_conf.txt

Here is something to add.
When opening Eclipse in the Java perspective again after the crash. There will be a new directory ‘vpproject’ where all diagramms which you wanted to create are shown. But those files just exist by name.

Hi Joss,

Thank you for your reply. I tried by using JDK 1.6 and Eclipse 3.3, but I regret that the problem can’t be reproduced.

Could you try with a new Eclipse workspace, create a new Java project, and run the described steps to see if you can repeat the problem? If you can, please send me the vp.log file that can be found inside the Eclipse folder and the VM log file (hs_err_pidXXX.log) that can be found inside the Eclipse folder as well.

Best regards,
Jick

Hi Jick

I seem to be having the same problem… my eclipse is crashing everytime I try to create a class diagram. I have tried for a new java project as well as my existing projects…

I am using:

  • Eclipse 3.2.1
  • JDK 1.6
  • VP Suite 3.1 (so I guess SDE 3.1)

My eclipse.ini config file is as follows:

-vmargs
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m

I have attached the vp.log file as well but have been unable to find the hs_err_pidXXX.log folder you mentioned.

Thanks.

Moe
vp.log

Hi Moe,

Thank you for your post. Can we hold an online meeting with you to take a look at this problem? The online meeting will be held over a secure connection. We’ll see your screen and may need to control it with your approval. If we can have a meeting, please let me know when you will be available and what time zone are you in.

Best Regards,
Jick