Ganymede(Eclipse) and SDE 4.3

I don’t seem to be able to install SDE 4.3(professional) into Ganymede(eclipse).

None of the Modeling feature come up.
Modelling-button is not there
Modeling-prespective cannot be found.

Installation was no problen with SDE 4.2m and Europe(Eclipse).

Is this a general problem !?

regards
Evan P.

Hi Evan P.,

Thanks for your post. I’m using Eclipse Ganymede as well but I do not have any problem on SDE installation nor modeling in Eclipse with SDE.

Please ensure that you are not using Eclipse CDT which we do not support. We support Java SE and EE, and only Java project is supported in SDE for Eclipse.

If this is not the case of the problem, could you please send me your Eclipse configuration details (inside Eclipse directory) for estimating the problem? Thanks in advance!
**Please save the configuration details as .txt extension and attach the text file when reply.

Looking forward to hearing your reply.

Best regards,
Lilian Wong

Hi Lilian,

I am having the same problem, and all of my students too.

Installation is fine, starting SDE succeeds, but the applicitions stills when creating a new model(both Class and UseCase model)

Can you be more specific what files you need to investigate the problem?

Thanks,

Hans

Hi Hans,

Thanks for your message. Could you please send me the following files for estimating the problem? Thanks in advance!

  1. eclipse.ini (inside eclipse directory)
  2. .log file of eclipse (inside %eclipse_workspace%/.metadata folder)
  3. vp.log file (inside eclipse directory)

Best regards,
Lilian Wong

[quote=LilianWong]Hi Hans,

Thanks for your message. Could you please send me the following files for estimating the problem? Thanks in advance!

  1. eclipse.ini (inside eclipse directory)
  2. .log file of eclipse (inside %eclipse_workspace%/.metadata folder)
  3. vp.log file (inside eclipse directory)

Best regards,
Lilian Wong[/quote]

Dear Lilian,

You will find the files included. The computer was only 1 day old with new windows XP installation.

I think the problem is caused bij Start Smart Development Environment Standard Edition for Eclipse [SDE SE-EC]: 4.3 (sp1_20080814).

because version [SDE SE-EC]: 4.3 (20080623) works ok in same computer configuration.
sde.rar

Hi Hans,

Thanks for replying with the files. Could you please send me the Eclipse configuration details as well? It’s in the Eclipse About dialog box.
**Please save the configuration details as a TEXT file and attach it when reply.

Thanks in advance!

Best regards,
Lilian Wong

[quote=LilianWong]Hi Hans,

Thanks for replying with the files. Could you please send me the Eclipse configuration details as well? It’s in the Eclipse About dialog box.
**Please save the configuration details as a TEXT file and attach it when reply.

Thanks in advance!

Best regards,
Lilian Wong[/quote]

Hi Lilian,

I enclosed the configuration details. I hope you come up with a solution soon, couse our lessons depend on SDE heavely.

Thanks in advance,

Hans
eclipse_config.txt

Hi Hans,

Thanks for your file. I’ve forwarded the issue to our engineers to investigate. If there is any news about this issue, I’ll notify you immediately.

Best regards,
Lilian Wong

Hi Hans,

Could you please try to start your Eclipse with “eclipse -clean”, or try with a new Eclipse and see if the application will free or not? Thanks!

Best regards,
Lilian Wong

[quote=LilianWong]Hi Hans,

Could you please try to start your Eclipse with “eclipse -clean”, or try with a new Eclipse and see if the application will free or not? Thanks!

Best regards,
Lilian Wong[/quote]

Hi Lilian,

It took a while to react but now it seems that most of my students are able to run SDE. So thank you very much for your advise.

Many Thanks,

Hans

Hi Hans,

Thanks for replying and it’s a good news that the problem is gone! If you need any help in the future, please feel free to contact me.

Best regards,
Lilian Wong

Recent product launchings and new project initiatives indicate that the Eclipse framework is spilling over from its IT origins to become a dominant factor in the embedded space. It may still take a few years to solidify its position, but Eclipse appears to be on its way to overshadow proprietary embedded tool chains.

micheel

buzz marketing

Uninstalling the SDE, cleanly (-clean option) running Ganymede and the re-installing SDE worked for me.

Hi Lilian.

I am having the same problem and the solution proposed not worked for me.

I attached the files you requested.
sdeFiles.rar

Hi user,

Thanks for your post and the files. Could you please send me the Eclipse configuration details (in the Eclipse About dialog) as well?
**Please save the configuration details as a TEXT file and attach it when reply.

Also, is there any step to repeat the freeze problem?

Thanks in advance!

Best regards,
Lilian Wong

Hello again Lilian.

I dont know what appends, but now i can open all diagrams without any problem.

And if helps for others, I attach the configuration and the steps to reproduce the error (until yesterday) are:

  1. Right click on the “Project explorer”
  2. Select “New -> Other”
  3. Select “SDE for eclipse -> Diagram”
  4. Select the desired diagram, “Finish”
  5. Frozzen window (seems like “working”).

PS. Maybe I forgot reinitialize the PC to take effect all changes with the configuration mentionated before.

Anyway, I apreciate your help.
eclipse_config.txt

Hi user,

Thanks for replying. I tried with your steps but cannot reproduce the problem… Anyway, it’s a good news that your problem vanished.

If you got any problem again, please do not hesitate to contact me.

Best regards,
Lilian Wong

I have got the same problem.

Frozzen window (seems like “working”).

Hi user,

Thanks for your message. It seems that you are the same user who submitted the same issue in the forum:
http://forums.visual-paradigm.com/posts/list/6646.html

Am I right?

Best regards,
Lilian Wong