"Generate Code" stops after "Generating mapping..."

Hi,

I used to create Java classes in JBuilder with the wizard out of an Oracke 9 db. This worked fine until I imported a new database (same scheme but different data). Now the wizard stops after the first step “Generatin mapping…-” and indeed there are only created the xml mapping files + the ERD and a Class diagram WITHOUT connections between the classes. The ERD has the connections.

What am I doing wrong?
I only have to start the wizard, no? Or do I have to create the diagrams before?

Help is much appreciated.
Thanks
dbva1.JPG

Hi Georg,

Did you create any ERD or Class diagrams for generating the ORM? Are the following your steps?

  1. Reverse the Oracle 9 DB into SDE for JBuilder.
  2. Generate ORM

I hope you could provide me with more detail. Thank you!

Best regards,
Jick

Hi,

what exactly do you mean by “SDE”?
I open JBuilder then click “Load DBVA PE-JB”.

Then I used to click “Modelling - ORM - WIzards”. Thats it.
The wizard let me choose scheme, tables, etc.
After the wizard was finished I had an ERD, a class diagram + the java classes.
Now the wizard doesn’t create the Class diagramm and the classes anymore.

I even can’t create a simple ERD with “Reverse DB”. I get an empty diagram…

Connection to DB works fine.

Any ideas?

ok, i solve the problem. thanks.

Hi Georg,

Sorry, I thought you are using SDE for JBuilder… :frowning:

I am glad to know that the problem is solved. If you have time, would you mind letting me know how did you solve the problem? If this is our problem, I will certainly ask our engnieers to fix it up.

Best regards,
Jick

This is solved, thanks!