How to make a copied activity independent?


#1

Hi everybody,

I copied an entire process as I wanted to use it as a initial draft but all copied elements carry this “a” on the top right corner and the original elements carry a big “M” on the top right corner. How to make it disappear and how to dissociate the original cells from the copied ones? I want to be able to update one without the other one changing.

Thank you!

Laura


#2

Yes, that’s because you didn’t make a copy of the elements but created a new view; an auxiliary view to be precise. As you suspected this means that you basically have a “virtual copy” of the model element (a new view) and both elements are ‘linked’ to each other. When you make changes in one it’ll be propagated in the other as well.

You can make the indicators disappear by using the “Model Indicator” option which can be found on both the View toolbar as well as in the pop-up menu: right click on an empty area in your diagram to open the menu, find the entry “Presentation Options”; this will show a sub-menu in which you’ll find the option “Always Show Model Element Indicators”. That can be used to turn of the indicator display.

Of course this doesn’t solve your problem but I wanted to mention it nonetheless because it might be useful to know.

When you use the copy/paste option using your keyboard (control-c and control-v) you’ll create a new view by default. So instead of using control-v right click in an empty area of your diagram (same as mentioned above) and find the option “Paste Model Element”. This will create a new copy of your elements instead of a new view.

I hope this solved your problem!


#3

It does, thank you very much for your fast answer!