Incosistent installation and CE does not run

Today, I downloaded vpumlce_20030520.jar community edition for VP-UML.

My environment:

OS: Windows 2000 with SP3
CPU: AMD Athlon 1.4 GHz
JDK/JVM: J2SDK v 1.1.4_01
RAM: 512 MB

I had following issues during installation:

  1. the command java -jar vpumlce_20030520.jar did not do anything…on DOS shell it just stays as if it is waiting for some input.

  2. I tried running same command with older version of jdk (JDK v 1.3.1_08) and actually it worked …I could go through the installation wizard specify all the needed input. The installer installs everything and then I tries to launch
    VP-UML and surprisingly it fails posting a message dialog that reads:

“Your Java Runtime Environment version is not able to run Visual Paradigm for UML Community Edition(Visual Paradigm for UML Community Edition should run on JRE 1.4.0 or above version).”

By selecting the message dialog must exit the java process but unfortunately it does not. I see in my TASK Manager the java process still live, i have to expolicitly kill it saying “End process”.

  1. Well, that said but not the end of story. Now, guess what, yes I tried to launch the installed VP-UML-CE with newer JDK i.e. v 1.4.1_01 (that is what I have on my Windows box) using following command:

java -jar vpuml.jar

java -Xmx512m vpuml

none of the above commands worked. For both the commands I see in TASK Manager that java process is created but nothing appears on screen.

Thanks for your help in advance.

Please try following command:

c:/jsdk1.4.1_01/bin/java -Xmx512m -classpath vpuml.jar;vpumlresources.jar RV jdk

Best Regards,

I tried that command but no success yet. Nothing appears on screen. After running the command I see in Task Manager a java process got created and it’s memory used is “21632 KB”.

Any other inputs ?