Instant Reverse Unsuccessful

When I try to instant reverse C++ code I am getting the error:
“Instant Reverse Unsuccessful. Reason: Error occurred in preparation.”

I have been able to successfully instant reverse Java source. Why is it having trouble with C++? Any clues, anyone?

Dear Anonymous,

Could you please send me the following items for checking the problem?

  1. vp.log file (under %VP-Suite_HOME%/bin )
  2. The C++ source you attemped to reverse

You can reach me at


I have this same problem. Can I send in my files too?

Thank you,
Perry Smith

Hi Perry,

Sure you can. I look forward to receiving your email.

Best Regards,

I have encountered the same issue. It looks like its a problem with launching some other shell/command.

From the log file:

[error] /Applications/VP Suite 3.0/bin/vp_windows/mac_doxygen: cannot execute
at java.lang.UNIXProcess.forkAndExec(Native Method)
at java.lang.UNIXProcess.(
at java.lang.ProcessImpl.start(
at java.lang.ProcessBuilder.start(
at java.lang.Runtime.exec(
at v.ztg.i(:195)
at v.ztg.i(:145)
at v.ztg.i(:137)
at v.imef.i(:280)
at v.imef.i(:194)
at v.afh.d(:63)

Hi hez,

Please give ‘execute’ permission to this file:

After that, the problem should be solved. If the problem persists,
please let me know.

Best regards,

That seems to have fixed it.

But now when I run through the instant reversal I don’t get any kind of out put. It says successful but nothing shows up in my current project.

Nothing in the log file.

Any suggestions?

hello hez,

Do you see any models appear in the Model Tree? If not, please send me the vp.log file produced under the bin folder of $vp-suite-install-dir.

Best regards,

Nothing appears in the model tree at all and as far as I can tell nothing shows up in the log.


hez@hez /Applications/VP Suite 3.0 $ cat bin/vp.log
[Thu Mar 15 21:33:58 PDT 2007] [message] [Thu Mar 15 21:33:58 PDT 2007]: Start Agilian Standard Edition [AG SE]: 1.0 (sp1_20070310)
[Thu Mar 15 21:34:20 PDT 2007] [message] [Thu Mar 15 21:34:20 PDT 2007]: Start Visual Paradigm for UML Enterprise Edition [VP-UML EE]: 6.0 (sp1_20070310)

Hi hez,

Is it possible to send me your code for reproducing the problem? If you mind posting here, you may send to my email address:

Best regards,

I have the same problem. I have given the execution permission recursively to all files in the installation folder of VP, but it could not help.

Hello kashej,

Could you send me your code and log file for reproducing the problem? You can find the vp.log file inside $vp-suite-install-dir/bin

Best regards,

I have given recursively read, write and execution access to all files in the install directory of VP.

If I :

  1. change to the /install-directory/bin folder
  2. start eclipse
  3. make “instant reverse” then it functions (instant reverse successful)

But if I start eclipse from some other directory, sde cannot find doxygen.

Dear kashej,

I recommend you start the Eclipse first, and then start SDE from within Eclipse. This should solve the problem.

Best regards,