Referenceless stereotypes on model explorer root

Hello everybody!

I´m wondering about an interface stereo type without references appears on model explorer root when creating an interface in a component diagram. There´re popping up more referenceless stereotypes on same root when dealing with stereotypes in class diagrams.

Does anybody has a workaround for this problem? I´d always like to have a tidy model explorer.

greetings, charon

Hi Charon,

Thanks for your post. You can right-click on the Model Explorer and select Filter Model Element in the popup menu, then you can uncheck Basics > Stereotype from the list to filter it (as shown as attached image). Please be reminded that this will filter all stereotypes of all model types.

Hope this helps. If there is any further inquiry, please feel free to contact me.

Best regards,
Lilian Wong

filter_stereotype.png

Hi LilianWong,

thanx a lot for your quick response. :slight_smile: Your post helps to filter the stereotypes correctly out of model explorer, but they still exist. Deleting them turns stereo type classes in default classes, so that cannot be the solution. Packaging them away results in creating new ones in root again. :frowning:

So what´s the reason for automatically creating these stereo types in model explorer root at all?

greetings, charon

Hi Charon,

Thanks for replying. The Model Explorer displays all model element in your project. The stereotype “Interface” is associated with the component model - if there is no stereotype with the component, it’s solely a component. Since the stereotype does associate with the model and exist in the project, it’s shown in Model Explorer.

If you think it’s more tidy to hide the stereotype in Model Explorer, I think filter model element is the best way for you.

Best regards,
Lilian Wong

Hi LilianWong,

thanx for replying. Yes, the filter is a temporary workaround but I just found out the filtered “Data Types” subfolder on model explorer root. It´d be nice if stereotypes used in the project could created in an equivalent subfolder called “Stereo Types”. With this consistent concept there even would be less confusion when navigating through my unfiltered packages in model explorer. Is there a possibility to implement this in the future?

greetings, charon

Hi Charon,

Thanks for your kind suggestion, and we will consider it. If there is any news on this issue, I’ll come back to you immediately.

Best regards,
Lilian Wong

Hi Charon,

I would like to let you know that we will support UML Profile in coming VP Suite 4.2. With this feature, you can define stereotypes for model element types on the Profile Diagram and and the stereotypes will be organized under the profile node (see attached image).

Also, you can refer to the flash movie at the following link for how this feature will work:
http://files4.visual-paradigm.com/res/profile-support/profile-support.html

VP Suite 4.2 will be released on 11th January 2010. If you would like to have the released candidate (RC) of VP Suite 4.2, please drop me a private message.

Best regards,
Lilian Wong

P.S. Happy New Year!
profile_node.png