Rountrip Engineering problems

In VP-Prefessional, VP-Enterprise and SDE-netbeans, roundtrip development is a real pain to use due to bugs in the engine.

I propose someone in VP-team actually start a new project and try developing a application by designing classes in the product, then do some work on the code, then syncronise, then model some more, then code some more.

You will find errors that will:

A) make you loose work
B) add duplicated lines in to the code because it get confused
C) make excess duplicate association link in the model because it gets confused
D) make you loose work and try again
E) waste days-and-days trying round-trip with the product, only to decide no to allow this tool near your code.

Considering the huge price increase one pays for these features it would be nice if these were fixed.

The bugs need to be fixed!

It would also be nice for feedback when i have been reporting these problems since january, i only got feedback when i was considering purchasing the product, but it has gone very quiet!

this is not good service! i would suggest you put greater effort into fixing problems and maintaining communication with your customers.

Hello John,

I purchased SDE-VS some weeks ago. I also had problems with roundtrip engineering, send questions to the support-team.

But …
I got (sometimes within one houre) feedback.
Yes, they couldn’t fix the bugs within this time, but i always got a workaround to solve my problem.

for me, i couldn’t say anything negativ about visual paradigm support

i have had problems since january, i have gone out my way to give sample files with errors etc.

I like the app, i just want it to work properly, then I will be more than happy so say VP are the best!

Dear John,

We are sorry for any inconvenience the problem caused you. Could you please send me more information about your problem, such as the vp.log file, sample projects that can reproduce the problem? You can locate the vp.log file under the bin directory of your NetBeans or under %VP Suite Installation dir%/bin directory. Please send the files to Thanks in advance!

Actually we are working on a new code engineering framework. Many of these problems will be solved with the new framework. The new framework are now planned to be available at the 5.1 - 5.2 version.

If you have any further questions, please feel free to contact us again.

Best regards,

I have sent earlier projects to Jik, he loaded the project and did see the problems and said they would be fixed.

A few weeks ago I purchased VP-Enterprise edition expecting these problems to be fixed (as i was reporting them when i first purchased SDE in January), i recently spent a long day trying to round-trip develop some simple code using my Mac running OSX only to find the same problems.

I then try to install IDE integration on new version of netNeans(4.1) and now netbeans complains of module error. I clean VP and netBeans from my computer several times to try and get integration to work. As VP has no option to remove IDE integration, each attempt requires uninstall of system. This took many hours of trying uninstall/reinstall of both NB and VP, but this does not work.

As there is many problems i discover on Mac running OSX on 64-bit G5 dual processor, I recommend you get one of these machines and do your testing on this (I have paid enough money for you to buy this machine)

Major Problems:
-Printing dont work
-code get deleted
-ide integration dont work with netBeans4.1
-models get multiple associations when sync to code
-object labels can disappear on large model and refuse to be named again, after saving
-each time the code is syncronised more an more duplicate ‘import’ statements are added to the top of each file

I really like the application, i has alot of potential, but round trip is a nightmare, printing is buggered, and there are some bugs that need serious attention to.


Actually we have just received our new Mac machine (with Tiger installed). We will do some test about on your problem. I’ve read through your problem list and I’ve fired report to related personnel to follow-up the problem. But I want to clarify 2 items in your list.

First, the printing problem is a general Java App problem caused by the JDK on the Mac platform. The JDK on Mac platform does not support the printing API. It’s is one of the know issue on Mac. Even the latest J2SE 5.0 Release 1 for Mac still didn’t support it. That’s why the diagram cannot be printed on Mac. In this case, I suggest you export the diagrams into image files and use some native application to print it our.

And for the IDE Integration on NetBeans 4.1, could you please tell me the build number of VP-UML that you are using. This problem should be fixed in some earlier version. If you are already running the latest version (20050422u) but still got the problem, please let me know.

Best regards,

This is good news that you have a Mac and will be addressing the problems.

The version I have been using is 20050222, I have tried 20050422 by removing VP and NB4.1, but no integration is apparent. I even try the VP ver2 beta with same result.

Regarding printing, I have other Java applications such as netBeans and Zend-Studio that seem to print.

I would recommend a full test of VP/SDE with NB4.1 on Mac, then try round trip engineering with it.

Fix it and i will be your number one fan!


ok, i try on a fresh machine and VP-UML now appears in netBeans tools menu, however it launches VP-Professional version instead of VP-enterprise, as i dont have vp-pro key it does not run.


Dear John,

You can re-adjust the product edition from Product Edition Manager, that can be started from ${VP-Suite_Home}/bin/VP Suite Product Edition Manager 1.1.

More information can be found at the following link:

Should you have any questions, please do not hesitate to contact me again.

Best regards,

the product edition manager display ‘enterprise edition’ already, i reconfirm this setting, netbeans still has link to ‘VP-PE’ even after restart.

Even with VP-EE running in background, it still try to lauch VP-PE .

unless you have a solution ready today, maybe you can supply me wth is professional-edition key to add to my licence repository?


Dear John,

Our engineers are now investigating on your problem. I’ll come back to you immediately once there are any feedbacks. We are sorry for any inconvenience this problem caused you.

Best regards,

printing a PDF report also does not work, but HTML report works.

Dear John,

We have tested the PDF report generation on the Mac and no problem was found. Could you tell me more detail about your problem? Or if possible, could you please send me some sample projects that can reproduce the problem also the vp.log file? You can find the vp.log file in the %VP Suite Installation dir%/bin directory. Please send the files to Thanks in advance!

Best regards,

Scrolling down it does appear there are extra pages in the .pdf, But the page index does not display in the pdf viewer.