Showing visibilty of a role

Hey,

I’ve searched in the forum and help but couldn’t find any answer :frowning:
I have a association between to classes marked with roles. The roles should be private so I changed the visibiliy of them. But where can I configure to show me that the role is private. I see the “-” only if i click on this role but I want to see it constantly.

Hello hcalex,

I will ask our engineers to see if we can support this.

Best regards,
Jick

Hello hcalex,

Your request will be supported in the coming version - Service Pack 2. I will inform you once that is out.

Best regards,
Jick

Hello hcalex,

Just to inform you that Service Pack 2, which support your request, is released. If you are using Service Pack 1, please run the product updater inside the bin folder of VP Suite installation folder to advance to the latest version. Please feel free to let me know if you have any questions about the fix.

Best regards,
Jick

I have the exact same issue with using Agilian 1.0 Standard Edition
(Build sp2_20070511) with not seeing the ‘-’ sign when set to private in the association.

Question: Can your engineers also look into this and bring out a new SP ?

Thanks,
PeterNL

Hello PeterNL,

Please try:

  1. Right-click on the diagram and select Presentation Options > Association > Show From Role Visibility
  2. Right-click on the diagram and select Presentation Options > Association > Show To Role Visibility

Best regards,
Jick

Yes it works. Only for me this would be a default setting. Nice to know where to find it.

Thanks,
PeterNL