Svn+ssh issues

I try to Join the Teamwork server and I receive the error message:

[error] ExecuteOutput err svn: Can’t create tunnel: The system cannot find the file specified.
[warning] login svn fail , errMsg : svn: Can’t create tunnel: The system cannot find the file specified.

what cold be causing this error? And how do I rectify it.

Here are the login details I am using:

Server: Subversion
Password: *****
Repository: svn+ssh:///home/repository/VP-SVN-Testing/
SVN Path: C:\Program Files\VP Suite 3.1\bin\vp_windows\svn\bin\svn.exe

Hi mjfi9ja2,

I’ll discuss with our engineers and come back to you a.s.a.p. Thank you.

Best regards,

hi mjfi9ja2,

It seems that your SVN has not configured the SSH program. We tried removing this line:
ssh = D:/apps/plink.exe -ssh -batch -l httpduser -pw 123456

in the configure file, and have received the same problem as yours.

Could you make sure you have configured the SSH program properly?

Best regards,

Where is the configuration file that I should be modifying??

Hi mjfi9ja2,

It should be at:

Best regards,

In the “VP Suite 3.1” folder I cannot see any folder folder matching the description you have given. There is no subversion folder. There are many config folders. What is the name of the config file? and is it in a different location for the version I have?

Hi mjfi9ja2,

The path is not related to VP Suite. A sample path is:
C:\Documents and Settings\Jick\Application Data\Subversion\config

It is about your Subversion server’s configuration. You may need to consult your administrator about this.

Best regards,


I faced the same problem with VP 5.1

I’m now at a point where it works when I put this line in my config file:

ssh = D:/Programs/Putty/plink.exe -ssh -batch -l xyz -pw xyz

Why do I have to specify login data in this config file? After all, it’s different for each server I use.
I tried omitting the login part and instead using the user/password field in the “Login to the Teamwork Server” dialog window, but it doesn’t work. The process that starts is: "D:/Programs/Putty/plink.exe -ssh -batch svnserve -t"
If I include my username in the repository path like svn+ssh://login@svn.server.xx/…/ Then it’s “D:/Programs/Putty/plink.exe -ssh -batch svnserve -t” But password is still missing. How are the 2 values of the dialog field handed over to the process? At the moment it only works by hardcoding it into the config file as a workaround.

Any solution?