Annoying "Whack a Mole" in html note export


#1

First time I noticed the problem, I assumed it was my fault.

There are 65 diagrams in my project, with a large number of in-page notes (using the “Note” element)

On exporting to html, I noticed that a bunch of notes were blank.

Went to the drawings, expanded the note element to ensure that the entire note was visible.

Exported to html. Fixed most of them. But then another DIFFERENT batch of notes went missing. Treated those. Re-exported and ANOTHER different batch went missing. Including some of those I’d already fixed and seen working properly in the previous export…

Am I missing something here? Is there a magic formula for ensuring that the notes get rendered properly?

There is no obvious similarity. At first I thought it was the larger notes. Fixed those and then some of the smaller notes went absent.

Need fix urgently!


#2

Hi HarryStottle,

I’m sorry about the problem you experienced. Our engineers tried to simulate your problem but without success. It looks like the problem is pretty specific to your project. Would you please send me your project file for diagnosis? You can send it to support-team@visual-paradigm.com for checking. Thanks and look forward to hearing from you.

Best regards,
Rain Wong


#3

That’s a disappointing response.

We’ve had this conversation before. I can’t let you near the project because it contains unprotected IP. Its the same reason we can’t use your cloud storage.

The problem is evidently with image generation. The workaround is to keep the good images in a safe place (and up to date) then, if a later html generation breaks one of the diagrams, just copy in a good backup.

Are you making any progress on reinstating the missing glossary links?


#4

We do have a project anonymous tool which can hash the content of your project into meaningless data. Do you think you can use this tool to hash your project and send us for diagnosis? Details about the project anonymous tool can be found at https://knowhow.visual-paradigm.com/technical-support/project-anonymous-tool/

Best regards,
Rain Wong


#5

I think that was suggested to me in my first few weeks and I rejected it at the time. Can’t remember why.
I’ll take another look…


#6

I’ve sent you an invitation to a Sync folder. That contains the anonymised project and a version of the html in a separate folder. See the “notes.txt” file for outline of the issues.


#7

Thanks for the files and our engineers are able to repeat the problem on our end. Please be patient and I’ll let you know once the problem was fixed.

Best regards,
Rain Wong


#8

Don’t know if this is related but because you now have an anon version I can use it to refer to a serious problem that has just occurred and which caused me first to reboot vp, then my workstation, then uninstall VP14.2 and upgrade to 15. None of which has fixed it.

I refer you to the diagram “Bri mouse Mou alar()” which as I say in the notes, I’m working on to implement my “hotspot” solution. My version of that page has become essentially unresponsive. All other pages/diagrams are functioning normally.

By unresponsive, the main symptom I see is the absence of the context menu accessible using right-click.

All I now see if I click on ANY object (none of which I can "select) is the ironic and irritating single word “Selectable”.

I’ve actually tested this in the anon version and that version is behaving normally, so this is something which appears to have changed in my version of the page since I exported it to you. Although on restoring a backup made just before that export, the problem still exists.

The diagram also has difficulty refreshing the page. Appears in patches as I move the mouse over different areas of the screen. (you could do with a “Refresh” button under your view menu, which is where we expect to find one)

The long and short is that the page has become virtually inaccessible, certainly unworkable. I’m hoping you can look at the anon version and see if there’s a likely cause, or else tell me how to troubleshoot it. This is urgent as I’m trying to hotspot every link throughout the project and as you can see for yourself that’s a couple of thousand hotspots I have to create. If something I’m doing is going to break the system, that’s a potential huge loss of time and effort so I need to know pretty quickly if it’s related to the hotspot fix.


#9

May I know the “My version of that page has become essentially unresponsive. All other pages/diagrams are functioning normally” in your message is meaning inside the VP application? or in the published result?

Best regards,
Rain Wong


#10

Within the VP project itself. Quite bizarre…


#11

I would like to let you know the HTML content on note element randomly not rendered in published HTML problem had been fixed. Please update the software to latest patch build (v14.2 build sp1_20180238ae or later, or v15.0 build 20180238bc or later) to get this enhancement. Details about update to latest patch can be found at

  • Please make sure you have pressed the “Update to latest patch” button on the left hand side of the dialog right after launching the update program

Regarding to the popup menu on element in VP client only showing Selection, it looks like caused by you turned off the selection to all elements in your diagram. Please right click on the blank area of your diagram and select Diagram Content > Make All Shape Selectable to resolve it.

And about the Refresh issue, we tested your sample on v15.0 but was not able to repeat the problem. Would it be possible that you can capture a video to show me how it behave on your end? You can send me the video via the support ticket. Thanks and look forward to hearing from you.

Best regards,
Rain Wong


#12

Seems to have fixed the text rendering. No errors after a couple of re-runs.
The patch update seems to have fixed the selection problem by itself but I’ll note that fix for the future.
Again, the refresh issue hasn’t poked its head above the parapet since the patch update. Sending a video would have to be based on the anon version so we’ll wait and see if it happens again.

So far so good.

Thanks

Harry