Cannot replace the default stereotype of a component

In the component diagram, the default stereotype of a component is «component».
I cannot see it in [right click it -> Stereotypes -> Stereotypes] so that I cannot remove it.
UML 2.x said that a component can be «buildComponent», «entity», «implmenetation», «sepcification», «process», «service», or «subsystem».
VP-UML is not provided «subsystem» for a component, so I added it manually.
(Note that the meaning of “subsystem” is different to UML 1.x).
But I got a component with «component» and «subsystem» after I doing it.
I believe that the «component» should be removed after I set the stereotype to «subsystem», but it didn’t.

By the way, I also noticed that the brackets of stereotypes are not formal.
It looks like a pair of double angle bracket ( << and >> ), and the formal way is using the guillemot notation (« and »).
Would you like to replace the double angle brackets to guilemot notations in VP-UML?
Example.jpg

spec.jpg

Hello tinlans,

Thank you for your message. According to page 149 of UML 2.1.2 Superstructure Specification, a component is shown as a Classifier rectangle with the keyword «component». Optionally, in the right hand corner a component icon can be displayed. Therefore it is not a stereotype and cannot be removed from the stereotype tab.

The «buildComponent» is really a standard stereotype for component, which is different to «component» keyword.

In fact, you can right click on the diagram and select Presentation Options > Show Component Option to hide away the «component» keyword. If you require any further information, please do not hesitate to contact me again.

Best regards,
Rain Wong

Hello Rain,

I also read this document again.
I know the «component» keyword is different to standard stereotypes,
but it’s very strange to show «component» and «subsystem» at the same time.

I think that the «component» keyword can be eliminated automatically when a component has a standard stereotypes,
because its placement conflicts with standard stereotypes.
You can also see page 689 and page 692 of UML 2.1.2 Keywords.
The notation placement of «component» and «subsystem» are in the box header(, and VP-UML decide to show both of them there).
It didn’t say that we must show «component» rather than «subsystem» in the box header.
So I think that it’s flexible.
We can put «component» keyword there, we can put «subsystem» there, and we can put «component» and «subsystem» there.

Many UML 2.0 textbooks hide the «component» keyword automatically when a component has any standard stereotypes.
For example:

  1. Learning UML 2.0, Russ Miles & Kim Hamilton, O’Reilly, April 25, 2006, ISBN 0596009828
  2. UML 2.0 in a Nutshell, Dan Pilone & Neil Pitman, O’Reilly, June 1, 2005, ISBN 0596007957
  3. UML 2 and the Unified Process: Practical Object-Oriented Analysis and Design, Jim Arlow & Ila Neustadt, Addison Wesley, July 7, 2005, ISBN 0321321278.
    etc.

And many UML 2.0 drawing tools are also using this behavior.
For example:

  1. MagicDraw UML
  2. Poseidon for UML
  3. IBM Rational Software Architect
    etc.

right click on the diagram and select Presentation Options > Show Component Option to hide away the «component» keyword.

This approach is really not convenient enough, since it effects on the whole diagram.
When I need a component with «subsystem», I have to follow this step.
And when I only need a component with «component», I have to revert it.
Would you like to add a global option for hiding «component» keyword smartly?

Thanks a lot.
learn.jpg
nut.jpg
up.jpg

Hello tinlans,

Thanks for replying. We will consider about this and will keep you informed on any news about this issue. If you require any further information, please do not hesitate to contact me again.

Best regards,
Rain Wong

Hello tinlans,

Our engineers investigated on this issue and confirm we will support it. I’ll keep you informed on any news about this issue. If you need any help, please do not hesitate to contact me again.

Best regards,
Rain Wong

I second this - There is no reason for every element on the diagram to display <>. Any news?

Oh, actually, there are now options to not show the keyword, which does take this off.
Thanks.

Hi user,

Thanks for your post and I’m glad to hear that you find the option. If there is any further inquiry, please do not hesitate to contact me.

Best regards,
Lilian Wong

I knew that functionality, but it’s not enough for me.
It affects the whole diagram, not a single classifer.

Hi Tinlans,

Thanks for your post. You can right-click on the component and select Presentation Options > Show Component Option > None in the popup menu (as shown as the image below).

If there is any further inquiry, please do not hesitate to ask.

Best regards,
Lilian Wong
no_caption.png