Can't connect to MS-SQL database

Hi my problem is best described with an image:

http://www.affeine.com/dbva.gif

The connection string is definitely valid. Any idea what the problem is?

Thanks.

Alan

Hi user,

You have to specify the Adapter file. Please press the green “down arrow” beside the Adapter file field to download the file, ‘Test Connection’ and proceed with the remaining steps.

Best Regards,
Jick

Hi

Thanks for replying so quickly, unfortunately I am still getting the same error. Have I missed something else?

http://affeine.com/dbva2.gif

Sorry if this is something trivial but I am a little confused.

Thanks

  • alan

Hi user,

May I know the build number (Help | About) ?

Please also try:

  1. Close the tool
  2. Remove the following items
    %vpsuite installation folder%\ormlib\driver\jtds-*
  3. Start the tool, and run code generation again
  4. Download the adapter file again

Looking forward to hearing from you.

Best Regards,
Jick

Hi

Ver/build: [3.1 - Build sp1_20060326]

I followed your steps and it didn’t seem to change anything. I received this message after downloading:

The Download File Connection Timeout: http://voxel.dl.sourceforge.net/sourceforge/jtds/jtds-1.2-dist.zip
URL: http://internap.dl.sourceforge.net/sourceforge/jtds/jtds-1.2-dist.zip
Downloading adapter driver
Finish to download adapter driver
Extract the download file
Done

Not sure what that message means - it says “Connection Timeout” but a file was downloaded in %/ormlib/driver/jtds-* so it worked… strange.

Hi user,

Thank you. Do you mean that the problem was solved?

Best Regards,
Jick

No, I still have the same problem as described in my first post.

-alan

Also, I should mention I have also uninstalled and then reinstalled the whole suite (including redownloading the adapter file).

We are evaluating a number of MDA tools for use in a large project and would like to trial your software but this is making it pretty difficult!

Is there a way around this problem? I would really appreciate a fix or perhaps an alternative (earlier) build?

-Alan

Hi Alan,

Have you configured the server properly to enable TCP/IP? Besides, are you using the default port (1433)? If not, please change the port number.

If the problem persists, could you please post a screenshot here (like your first post) to show the problem? I will ask our engineers to provide with more information.

Best Regards,
Jick

Hi,

I’m having the same problem, our dev sql server works fine with everything else and is correctly configured for TCP/IP on 1433.

I’m quite impressed with your product and I REALLY want to get the generate Database part working but I cannot connect. Save situation as the other guy, good connection string, just downloaded the new driver etc.

Any ideas?

DB.GIF

Hi user,

I have passed your problem to our engineers to follow up, will post here once there is a reply from them.

Best Regards,
Jick

Hi user,

If possible, please use SQL authentication instead of Windows authentication. If you really want to use Windows authentication, please replace user id and password with “Integrated Security=SSPI”, e.g. “Server=localhost;Database=Test;Integrated Security=SSPI”.

Notice that by using Windows authentication, test connection will fail in DB-VA, but the generated code can work well.

Best Regards,
Jick