Can't download optional download .jar

I’ve tried to use Generate Code function from Model menu. everything seems to work fine but when I got the source files. All of them have error about can’t import org.orm.*.
I thought it came from some optional .jar was missing. Then I’ve tried to use an auto download from “Database Code Generation” dialog box and click at “Select Optional Jar” button.
I’ve got a connection problem. I’ve no proxy to connect to internet. I can update VSuite as normal tonight. So, i’ve no idea why I got Connection Problem. My SDE-Eclispe is version 20061004.

How can I download them separately from VP website? I think it’d included inside VP package. May be I’ve not seen the download link from VP website before.

So, how can I download these optional jar files?

For more clearify my problem. I’m looking at this URL.

And try to do at step “Selecting Optional Jar for Persistent Library” but can’t download the optional files at all.

Hi Jedt3D,

Thank you for your post. I am glad to inform you that the problem is just fixed. Please download the hotfix at:

The following page shows you how to install the hotfix:

I will post again when a complete release is ready.

Best regards,

Thank you very much, Jick.

I’ve reinstall the vpplatform.jar and run the for update. My splash screen show version 20061006p.

I’ve used Wizard from ORM menu and try to download the optional jar file again. No luck. It’s show…

Cannot download jar file: ORM Core
Please check proxy settingCannot download jar file: ASM bytecode library
Please check proxy settingCannot download jar file: ASM Attribute
Please check proxy settingCannot download jar file:ANTLR 2.7.6 RC1

and so on…

Btw, I’ve found these files inside $VPSuite/ormlib and $VPSuite/ormlib/optionaljar directories. When I use some neccessary files and repack with orm.jar, it’s work with my project.

What’s the different with the files that I’ve to redownload ? Do I have to redownload everytime I reverse database? (C’mon…)

I think it’d be packed within the VP SDE update. Or may be because you have licensing issue?

Hi Jedt3D,

Sorry about this. I forwarded your reply to our engineers. I will come back to you as soon as possible.

Best regards,

Hi Jedt3D,

Our engineers replied me that the files you listed are not optional jars and are not require to download.

Could you check if they exists in eclipse/sde/ormlib?

If they exists, could you provide me with the steps to repeat the problem?

Best regards,