Change size of large class diagram

Hi,

I’ve reverse-engineered a large number of C++ files into a lot of elements. I want to create a class diagram from all the elements, so I select all the elements and use the form diagram option to create a big class diagram.

I want to change the size of the class diagram so I may print it out. As of now, the diagram will take about eighteen 36"x48" pieces of paper. Looking at the diagram, most of the space taken up by the diagram is in the form of connector lines. I tried to drag all the generated diagrams to the upper-left corner of the class diagram so it could be printed out on two-four sheets, but on print preview it will still print out the excess whitespace.

Is there a way to make a tremendously large class diagram smaller, so I can print it on a few pages as opposed to twenty?

Hello Djaunl,

I think that our Printing feature can help you. I captured a screenshot to show you how it can help. Please find it attached.

Best regards,
Jick

printing.png

[quote=Jick]Hello Djaunl,

I think that our Printing feature can help you. I captured a screenshot to show you how it can help. Please find it attached.

Best regards,
Jick[/quote]

Hi, thanks for the reply.

Unfortunately, that is not what I am looking for. Here is a screenshot that will help me explain:

As you can see (ignore the odd setup; I dragged the elements around a bit), although I can use the fit to page feature, the majority of the class diagram’s space is taken up by connector lines. Furthermore, there is a large amount of whitespace on the right side of the class diagram that takes up more space.

Is there anything that can be done to perhaps make the connector lines shorter, so that the diagrams can fit in a smaller space on the page, and eliminate the whitespace?

Thanks,
Dan

Hi again,

Sorry to bump this thread, but I still have not found a solution. Is there a better place I could ask for support than these forums?

VPUML seems to have all of the features I want in general, but issues like this that should be resolved easily but cannot seem to be make me very hesitant about purchasing the product.

Dan

Hi Dan,

I would suggest you adjust the parameter of layout and run the layout again. In order to make the diagram looks more compact, you may try reduce the grid size in Orthogonal Layout. Here are the steps:

  1. Right-click on the diagram
  2. Select Layout > Customized from the popup menu
  3. Reduce the Layout Grid Size
  4. Confirm
  5. Run Orthogonal layout on the diagram.

If this does not help, please try other ways of layout as well.

Hope this helps!

Best regards,
Jick
grid-size.png