Columns Hiding/Showing in ER Diagrams


#1

Hi,

I would like to know if it is possible to hide some columns in Entity Relationship diagrams?

Best regards,

Sami


#2

Hello Sami,

You may hide columns by right-clicking on the ERD and de-selecting Presentation Options > Show Entity Columns from the popup menu.

Best regards,
Jick


#3

[quote=Jick]Hello Sami,

You may hide columns by right-clicking on the ERD and de-selecting Presentation Options > Show Entity Columns from the popup menu.

Best regards,
Jick
[/quote]

Hey,
thx for the answer, but I would like to hide just some of the columns not all of them.

Sam


#4

Hello Sam,

May I know the reason for hiding just some of the columns? Any criteria for the columns being hidden?

Best regards,
Jick


#5

Hi Jick,

Yes, off course, it’s just that some Columns are not relevant for the diagram. Like you have a big diagrams showing all entities and columns, and other diagrams for part of it. So when doing technical analysis, I would like to show only columns necessary for that specific analysis.

Best regards,
Sami


#6

Hello Sami,

Thank you for you feedback. I’ve forwarded your need to our team for further feasibility studies. Once there is any reply, I’ll let you know.

Best regards,
Jick


#7

Hi,

I know it’s a very old thread but I’ve got a similar problem. In Visual Paradigm for UML version 8.0 for MacOSX, I can’t find the “Show Entity Columns” Checkbox.

I can see the Presentation options. There are “Show column types”, “Align Column Properties”, “Show tagged values” and so on. But there is no “Show Entity Columns”. Where can I find it? Is it not possible in the OSX version?

In the VP Resource i found a article about this:
VP Resource

Best regards,
Kevin


#8

Hi Kevin,

Thank you for your post. The article is very, very old. The popup menus are rearranged. For the latest version, please right click on the background of diagram and select Presentation Options > Entity Columns Display Options > Show Entity Columns from the popup menu.

In the latest version, you can also select specific columns to hide. Right click on specific entity and select Presentation Options > Show Columns Mode > Customized… from the popup menu. Then, select columns to show/hide.

Best regards,
Jick Yeung


#9

Hi Jick,

Thank you very much. I right-clicked the diagram in the “Diagram Navigator” and not the Background of the diagram.

It works well.

Thx,
Kevin


#10

Hi Kevin,

Please right click the diagram (i.e. the drawing with shapes in it), instead of the diagram node in Diagram Navigator.

Best regards,
Jick Yeung


#11

Hi,

I know this is a very old post, but I think creating a new one would spread the relevant info so I add my question here.

I need to hide foreign key columns from entities in my E-R diagram. I can’t find a way to do so (of course I could manually select all the existing foreign keys and hide them) but I’d like the following behaviour: when adding a new relationship between two entities, the foreign key column shouldn’t be visible.

Is there any way to do so?

Regards

Samuel


#12

We are sorry that there is no option for your case.
However, your feature request is passed to our engineer to enhance to support.
We will notify you once it is supported.