Consistent problem running latest version

I’m having a consistent problem on my laptop with both the No-VM install-anywhere version of VP and the no-install version. They both install and run just fine, and show the “loading” splash screen, but the progress bar gets about 3/4 of the way across and freezes. CPU usage goes to 0% and the window will sit there until I kill it.

I attached my vpuml.log file.

My environment:
Redhat 9.0 with all current errata on a Dell Latitude CPx laptop
java -version:
java version “1.4.1_02”
Java™ 2 Runtime Environment, Standard Edition (build 1.4.1_02-b06)
Java HotSpot™ Client VM (build 1.4.1_02-b06, mixed mode)

I got the no-install version running on my XP box without any trouble, although I did have to use the no-install rather than the no-VM version (my XP box also has Java 1.4.1_02 on it already). I notice the program GUI comes up when the progress bar is at the same place it freezes on my laptop. Any advice would be much appreciated :slight_smile:

Just a few words of praise:
I tried Objecteering, ArgoUML, UML Pad, and Visual Paradigm, and VP was the only one that had the feature set I needed and was also usable enough to lay out the complex project I’m working on. Now if only I could get it running on my laptop, I’ll be in great shape :slight_smile:

Thanks in advance.

Please download the Linux platform installer to install in your Linux box.

Best Regards,

I downloaded the linux installer this evening and tried again, and had the same problem. I’ve now tried each installer except the windows no-install version. Anything else it could be?


Please try to run it using command line:
java -cp vpuml.jar;vpumlresources.jar RV

and make sure that you are using right jdk
java -version

Best Regards,