Copying activity diagram within a project

I am trying to copy an exsiting activity diagram within the same project.
I have used crtl a (select all), ctrl c (default copy), opened a new activity diagram then ctrl V. The original diagram contents are pasted however most of the shapes appear to have lost their “connection” to the underlying grid and have pasted on top of each other also control flow lines and their text descriptions have been separated. Its a nightmare to unravel this manually. I have tried various (all possible?) ways of cutting and pasting with the same results. Any ideas -please?

Dear Pam,

Sorry about the problem. As I remember, the bug associated with copy-and-paste had been fixed before. Could you please send me your log file so that we can locate the cause of problem easier? I would be greatful if you can send me your project file for testing.
(You can find the vp.log file under %VP-Suite_HOME%/bin)

You can reach me at

Best Regards,

Just a thought, try export the activity diagram and than import it back into your project (model), when you do rename the diagram.

It might help you out untill they fixed the bug.


Tried the export/import suggestion - no luck. I exported the activity diagram as suggested, renamed it, edited it, saved project and then imported back into “master” project. The changes I’d made were all updated but… it had over written the original activity diagram. I tried again including the Use case diagram to which the activity was linked and played around with editing the activity diagram attachment before renaming and re-importing - still no luck. The import function does not appear to append - is this another bug?

Hi Pam,

It is not a bug as the core mechanism of project import functionality is to merge the changes from a source project to the ‘master’ project.

Best Regards,