Disable "Display as Robustness Analysis Icon"?

I’m using VP for UML 6.4 from VP Suite 3.4. I’m attempting to use <> and <> stereotypes in both my Class diagrams and Sequence Diagrams. When I do it changes the box icon to the “Robustness Analysis” icon. This is not desirable for me.

I have gone into the Tools > Prefrences > Diagramming > Class > Presentation area and disabled the checkbox for “Display As Robustness Analysis Icon”. Nothing has changed in either the Class diagrams nor the sequence diagrams (is there a place for this option in the sequence diagrams?)

How do I fix this? I love this tool but this is very frustrating.

Hi Tmscase,

Thanks for your post. The options at Tools > Options > Diagramming > Class > Presentation are for new class diagrams. for existing class diagrams, please right-click on the class diagram and select Presentation Options > Configure Class Presentation Options to disable the “Display as Robustness Analysis Icon” (see image).

If you want to change this presentation on specific class, please right-click on the class and select Presentation Options > Display Robustness Analysis Icon to disable it. Hope these help.

Best regards,
Lilian Wong