Eclipse integration (ubuntu)

OS: Ubuntu 18.04.5 LTS
Eclipse IDE Version: 2020-09 (4.17.0)
Visual Paradigm version: 16.2 (Build 20200904)

After using Window -> Integration -> IDE integration… and completing the steps with the wizard I get a message saying I should now be able to use Visual Paradigm from within Eclipse.

Trying this I can see the splash screen for Visual Paradigm, but then 2 tiny windows open in the upper left corner of my screen. I can only enlarge one but it’s an empty gray window. Nothing else seems to happen. After this I can’t even close my IDE anymore and I have to force it to shut down.

I’ve uploaded a screencast which shows exactly what happens to youtube:

Tried a lot of different things to get this resolved, but so far I have not found a solution.

Things I’ve tried:

  • upgraded operating system to Ubuntu 20.04.1 LTS
  • switched from the official JDK 14.0.2 to openJDK 14 (this results in a JVM crash with exit code=127)
  • added -Dsun.java2d.d3d=false to eclipse.ini

Hi Kasper,

Thank you for your post and sorry about the problem. Could you submit a formal support request by including the problem description, your screenshot and your log file? You can export your log file from Visual Paradigm’s About window (Help > About).

Please submit a support request here:
https://www.visual-paradigm.com/support/#support-form

Best regards,
Jick Yeung