Editing Class-Entity & Attribute-Column mapping

In my project, I have Classes and the corresponding Entities. If I need to give the mapping between them. What is the best way to do this ?

I tried to create a ORM diagram and dragged the classes and entities there. I could set up the mapping between Classes & Entities through Class-Entity mapping option.
But I could not see an option to provide the mapping between Attribute & Columns. Is there a way to do set up Attribute - Column mapping before I start code generation ?

Sample ORM Diagram is attached.

Note: I receive ER diagram from database group, so I do not create entities. My job is to provide the link between classes and entities before generating code & hibernate mapping files.
Sample ORM Diagram.gif

Hi rameshg,

Thanks for your post. By default, the classes/entities generated via synchronization will be mapped automatically. When you right-click on the ORM diagram and select View > Attribute Mapping in the popup menu, the mapping between the columns and the attributes will be shown.

If you want to map existing unmapped classes and entities, simply select the column and drag over the attribute to create mapping. Here is the link of the flash movie showing how to create mapping between existing unmapped classes and entities:
http://files3.visual-paradigm.com/200804/Lilian/movie/attribute_mapping.htm

I hope these will help. If there are any inquiries, please feel free to ask.

Best regards,
Lilian Wong

That was very clear and helpful. Thanks !

Well, it worked. But once I map the Class to some entity, later I am not able to change the mapping to a different Entity. Say, first I mapped Class1 to Entity1. Then I realized it is wrong, I should have mapped it to Entity2.

I tried deleting the Class1-Entity1 mapping line from the diagram. But it somehow doesn’t go. When I refresh the diagram (change the View to Attrib mapping and switch back to Class mapping), Class1-Entity1 mapping comes back.

See attached image. By this time I have deleted the Class1-Entity1 Mapping. It is not showing up in the diagram. Now I want to set the mapping between Class1-Entity2. So I click Class-Entity mapping from the tool bar and then mouse over Class1, I am not allowed to click on Class1.

Change Entity Mapping.gif

Hi rameshg,

Thanks for replying. I’ve forwarded your details to our engineers to follow-up. If there is any feedback, I’ll inform you at once.

Best regards,
Lilian Wong

Hi rameshg,

I would like to let you know that the problem about deleting Entity-Class Mapping is fixed in our application. Please download the patch in the following link and have a try to see if it works.
http://files3.visual-paradigm.com/200804/Patch/sp1_20080417a/VP_Suite_Windows_3_2_sp1_20080417a.exe

To use the patch:

  1. Exit any running instance of VP
  2. Install by overwriting the current installation
  3. Restart the product.

Note: This patch is made for VP Suite 3.2 SP1 (VP-UML 6.2 SP1). Please make sure you have a valid product license. Otherwise you won’t be able to start up the product after the installation.

If you need any assistance, please do not hesitate to contact me.

Best regards,
Lilian Wong

Dear Lilian,

i tried to watch the linked flash movie (http://files3.visual-paradigm.com/200804/Lilian/movie/attribute_mapping.htm)
but the file is not there anymore.

could you please re-upload the file?

thx.
best regards
Sebastian

P.S. it seems the forum searchengine is broken. after more than 15 minutes still no result.

Hi Sebastian,

Thanks for replying. We are sorry that we have re-organized our files in the server, please view the flash movie at http://files2.visual-paradigm.com/FlashDemo/attribute_mapping.htm

If there is anything I can help, please feel free to contact me again.

Best regards,
Lilian Wong