Error code DB0001


#1

Hello,

When I try to generate a database into PostGreSQL, I get the following error :
"Fail to generate datbase due to no physical entity in the project. (Error Code: DB0001).
I am sure that I did something wrong, but what ?

Thanks for the help.


#2

It looks like your ER model are defined in conceptual/logical data model, that’s why it prompt that no physical entity was found for DB generation. You can right click on the blank area of your diagram and select Data Model > Physical to change the ERD into physical model for DB generation. Hope this helps and feel free to contact me for any questions.

Best regards,
Rain Wong


#3

Hello,

Sorry for the late reply.
I somehow mixed conceptual entities (and relationship) with physical ones. I tried to change each of them from conceptual to physical. But it did not work and i still have the same error. So, I exported my ERD in xml format, then re-imported it and it works now.
Thanks for the help.
Bu I have another question, is it possible to reanme quickly some column name from abcDef to abc_def ?