[error] java.lang.NullPointerException where update a project


#1

Hi, I’m having a problem with my VP server.

When I start to update the project, I get a pop-up error message: java.lang.NullPointerException.
A week ago everything worked fine, now it gives this error. When I try to create a new workspace, I do not take a checkout from the repository


#2

Dear vikkiorrikki,

Thanks for your inquiry. Would you mind attach your log file? It can be exported from the About dialog.
If you don’t want to post in the forum, you can send it to support-team@visual-paradigm.com and include the link to this post in the Email.


#3

Dear vikkiorrikki,

We checked your log file. Please try the following steps to solve the problem:

  1. Enable engineering mode in About Dialog
    EngineeringMode
  2. Open “Teamwork Client”, enable “Validate diff before apply” in “Maintenance” menu
    ValidateDiff
  3. Update/Commit project as usual

#4

Hello.

Unfortunately, "Maintenance” menu is missing. Only “Session”, “Project”, “Repository”.

123


#5

Did you enable engineering mode and restart?


#6

Yes.
1234

But…In the menu of the Teamwork Client nothing has changed


#7

I’m sorry that missing one more step.
Please also enable “Advanced UI mode” in Application Option.


#8

Thank you so much!! Everything is working


#9

You’re welcome and I am glad to hear that the problem was solved.