Evaluation Key Not registering

I am trying to install SDE for VS professional edition on my machine, i had previously installed the for UML version (community lisence) which worked fine. I then tried the SDE version which will not allow me to add an evaluation lisence key???

The import is successful but the key does not show up in the list and then i get a prompt informing me the keys are invalid. This then locks up my visual studio and i need to use task manager to close it?

Please let me know what i can do…

Dear Dan,

Thank you for your message and I’m sorry for replying you so late. One of the possible cause of the problem is due to the key is not compatible to the software (either the product or edition). You can see all your imported key at the License Key Manager by turning on the Show All Products and Show Expired options. If you found that the imported key really not match to your software, you can re-request the key using the Request Key button at the top of the key manager. Should you have any queries, please feel free to contact us again.

Best regards,