How do we create custom hotkeys?


I can find a reference to how to “copy” custom hotkeys (to another workspace) in this forum, but no mention of how to create them in the first place. I’ve downloaded the help but it’s not searchable and the one place where I might have expected to find it (Customise UI) had no mention of hotkeys.

Having now right clicked to “Paste a Model Element” about 2,000 times in the past few weeks, I’m getting bored of it! How do I assign it to a hotkey?


Hi Harry,

You can configure hotkeys for actions in the Application Options dialog box (from menu Window > Application Options). Select “Keys” from the left, and search for the action that you want to assign hotkey to. Type the key combination in the “Binding” text field, then restart Visual Paradigm for the change to take effect.

Hope this helps,



Or if the target diagram you want to paste model element is the same as the source diagram element, you can use the Duplicate action (which has the hotkey Ctrl + E assigned by default). It is in fact the same as copy + paste model element, but you saved one key stroke.



Both of those work. Wish I’d asked earlier. It would have saved about 3 hours and an RSI.

There are, however, limitations in the hotkey assignment.

My preferred option was to “unbind” the standard “paste” assignment (Ctrl+V) which, in VP, is dangerous because it creates a dependency (between “Master” and “Auxiliary”) and reassign it to the much safer “Paste Model Element”.

I unbound the Paste, assigned Ctrl+V to “Paste Model Element” and restarted VP. It had reassigned Ctrl+V to the “Paste” command and cleared the binding on PME. So I tried a different route. Left paste as it was and assigned Ctrl+Alt+V to PME and that worked.

But, had I known about Ctrl+E I needn’t have bothered!

What this reveals is the perennial problem with ALL complex software. None of us (myself included) has perfected the help files. I’m sure that information is buried in your documentation. I spent more than an hour looking for it and failed. Even googling “Visual Paradigm” and “custom keys” (and variations) failed to locate the information.


So you mean you failed to unbind the Paste command? I just tried and it has no problem. Have you ensured you pressed the Backspace key once in the “Binding” field to clear it instead of just assigning the same hotkey to “override” it? When you click OK/Apply button in the Application Options dialog, if you see the “Binding” column of the Paste command is cleared as screenshot, you should be good to go.

I can prove that because I also tried to Google it before replying you, so I can just point you to existing resources if they are already available. The materials are in fact there but they seemed not very well indexed by the search engine.

But here’s a tip: to look for an option/setting/configuration, you can try search it either in the “Application Options” or “Project Options” dialog box. As their names suggest, they refer to the options that are global, and options that are project-specific respectively.

However, even for experienced VP user like me, it is often hard to determine whether an option is application scoped or project scoped, in such case I would first try find it in project options, and then the application options.

A rare exception is the “Customize UI” command, which lets you show/hide specific UI elements, and it isn’t in either dialog boxes but as a command on its own.


Didn’t do that. Just clicked “Unbind” and it cleared the field. Then I moved down to the PME command and assigned Ctrl+V

However, after all that, turned out to be considerable less useful than I’d hoped. The advantage we get with the right click approach is that the Paste command takes, as its starting point, the current cursor position. THAT is actually more useful to me than the hotkey, which creates its copy right next to the copied element (which I then have to move to the right place).

The materials are in fact there but they seemed not very well indexed by the search engine.

have a word with your webmaster. They may have something like “norobots.txt” preventing Google crawling the documentation.


Sorry didn’t even realized there’s the “Unbind” button, I tried and it works for me as well.
Thank you for your suggestion about the search engine optimization, I’ll let the webmaster know about this.