How to import/export UML Model between Linux-Windows corretly?

I’ve to use between SDE-EC for Windows and Want to send back to Linux side for some task. But I’ve got the problem.

  1. I want to attach an image inside the diagram. When I’m on Windows, I can drag & drop from desktop -> diagram directly.
    Problem ----> Not show in Linux or even on anoter Win machine.

  2. If it can’t be possible, I can trade off with using Open Specification in each diagram opject. Then goto References tab, add an image ther + type some description. But…
    Problem ----> I can’t open the .vpp file inside linux with image that attached from Win by this method.

  3. I’ve try to set up a variable in Application Option->Use Path. I’ve set up a ${VPImages} variable in both Windows and Linux side. Then try with the 2. method. And file .vpp & .jpg they refered are in the same folder. In my case, all files are save in C:\vpimages and ~/vpimages.
    Problem ----> I’ve seen some diagram element have link in side Refences tab, someone’ve not. But the one have link didn’t have a correct image link at all even it has “${VPImages}\myimage.jpg” inside their field. I’ve to change from “” (Win) to “/” (*nix) then it can link correctly. So, all I think is the problem may came from this “Slash” problem?

  4. Another problem, even I link image via Reference Tab in Linux. It’s not open a default image viewer.
    Possible solution ----> Can you set up an option for default HTML, Text, Image viewer when I right click and select a link file from each diagram element?

  5. Not a real problem but I want a solid workflow to use SDE-EC between Linux & Windows or even Windows & Windows via Import-Export UML Model. (Or something else that work). Esp. with image attached somewhere inside a diagram.

  6. Some suggestion, you should add an Insert Image button with the HTML textarea in Definition dialog box too. Since it has Table, List, Bold etc already.

    Please help me find the way out. It’s the pain for me to draw a diagram without image for describe what I want!.

Best regards
Jedt Sitthidumrong

Follow up the problem…

  1. As I’ve test, the problem of lost attached link should come from “” - “/” issue. If you can make it use “/” in Win version of SDE, it’d work well. I’ve to manually edit every links.

  2. The attached file name didn’t open correctly if the file name is not English. In my case Thai language or Thai-Eng mixed up. I’ve tested with .txt, .pdf, .jpg file types.

  3. I think an option for default editor/viewer for each file type should be neccessary. Since on Win, .jpg open with my default software (IfranView), .txt open wth UltraEdit but .pdf file open with Acrobat Reader.
    —> All of this file types were not open with a default viewer in Linux at all.

Should help you guys track bugs or implement features a little bit. Please help.

I forgot to mention my system.

All are on the same machine.
Windows XP SP2. Core Duo 1.6 GHz, RAM 1.5 GB
–Sun Java 1.5.07
–Eclipse 3.2 + Latest update SDE-EC via vpupdate.
Ubuntu Linux 6.06
–Eclipse 3.2 + Latest update SDE-EC via vpupdate.
–Sun Java 1.5.06 (work as primary alternative Gnu VM)

plugins that install in the same eclipse
– Instantiations’ CodePro & WindowsBuilder Pro.

What I’ve drawn is just a simple BPMN diagram. Only one diagram in the project. Exchange between platform via Import/Export UML Model command from the File menu.

Best regards
Jedt Sitthidumrong

Hi Jedt3D,

Thank you for your post.

I can repeat the problem that image cannot be dragged from desktop into diagram in SDE-EC under Linux environment. I also reported this issue to our engineers. However, I do not understand the point about unable to show on another Win machine. Do you mean that you have two Win machines, one can attach an image through drag and drop, one can’t? Or, you mean that you couldn’t open the project file that contains an image created by drag and drop created by another Win machine?

I am sorry, but I cannot repeat this problem. Could you provide me with the steps in point form?

3 (and pt 1 in the 2nd post).
I can repeat this problem, and already reported to our engineers. Thank you for your observation.

  1. May I know which tool are you using for the default image viewer, and which tool SDE-EC opened for reading your image? You also mentioned HTML and Text, could you let me know about any situation, as you discovered, that SDE-EC is not using the default application to open your file?

To export a SDE-EC project:

  1. Save your project (if necessary)
  2. Close SDE-EC if it is running. To close, select Modeling | Close SDE-EC from the popup menu
  3. Right-click on the Java project node and select SDE-EC Project | Export SDE-EC Project… from the popup menu

To import a SDE-EC project:

  1. Close SDE-EC if it is running. To close, select Modeling | Close SDE-EC from the popup menu

  2. Right-click on the Java project node and select SDE-EC Project | Import SDE-EC Project… from the popup menu

  3. and 3. (2nd post)
    I will pass your suggestion on to our developers. Thank you for your feedback.

  4. (2nd post)
    I already informed our engineers about this.

Best regards,

Hi Jedt3D,

For the problem that cannot open file with filename in Thai, we discovered that it can be solved by editing the Windows regional setting. Please follow the steps below to solve the problem:

  1. Start Control Panel from the Start Menu
  2. Double-click Regional and Language Options
  3. Open the Langauges tab
  4. Inside the Supplementary language support section, check ‘Install files for complex script and right-to-left languages (including Thai)’
  5. Restart Eclipse and SDE-EC

This is how we solve this problem. I hope can help you solve the problem. If the problem persists, could you try if VP-UML works? Thank you!

Please let me know if it works. Thank you!

Best regards,

Hi Jedt3D,

The problem caused by slash is also fixed. But there is another issue that cause the files cannot be opened in Linux. I will post again when that issue is solved.

Best regards,

Hi Jedt3D,

After a series of researches, we found that it is not possible to support dragging file from desktop to SDE-EC at this moment. This is somehow related to the JDK. I am sorry about this.

Best regards,

Hi Jedt3D,

One of the problem you reported, about unable to open file in Linux, is fixed in the latest version, which was released yesterday. The fix is to employ a way to let you define which application or command to use to open a file with particular file extension. For details, please read:

Please feel free to let me know if there are any questions.

Best regards,