I found error "The jvm could not be started. The main method may have thrown anexception."

I use VP-UML-EE for year but when i move it to window vista, i found error “The jvm could not be started. The main method may have thrown anexception.” Could anyone help me?

Hi user,

Thanks for your post. If you enabled user Access Control on Vista, please try to right-click on the launcher of VP-UML and select Run as Administrator in the popup menu.

Alternatively, please start VP-UML and disable Auto Update at Tools > Options > General > Update (select “Never”). After that, restarting VP-UML should not have the same error again.
Then when you want to check whether there is update of product, you can run “VP Suite Update” inside VPSuite/bin folder to check.

Hope this helps. Please feel free to ask if there is any question.

Best regards,
Lilian Wong

Hi I am using VP 8.0 on windows 7 and i always get this error “The JVM could not be started…” I tried to disable all noon microsoft services in msconfig.exe as manual startup, sometimes it works but most of the time it prompt this error message. I also tried to change the AutoUpdate Mode in VP but i still encounter this problem. The only way to get around this and work on VP is to launch windows in safe mode.

Please help, you have a great software but what’s the point if there is no way to access it.

Thank you in advance!!

Do you mean you have turned off the auto update but still have this error? Have you tried to run the application in Admin mode, or turn off UAC and see is it working?

Best regards,