Importing XMI file created using Papyrus


#1

Hi,

I am evaluating VP and I am trying to import an XMI file that is created in Papyrus. I am using VP for Mac and here is the error that I got:

[error 18:48:14]XMI file is not supported, xmi-version: 20131001, exporter: not found, exporter-version: not found, file: SID Models.uml (/Users/moismail/workspace-papyrus4/SIDModel18V6/SID 18.5/SID Models.uml)

Regards,
Mohamed Ismail


#2

Sorry, there is a bug on checking xmi:version.
The problem is just fixed, and will be available in next patch (I will post here when the patch is ready).

FYI:
I just test with the ProjectManagement example (https://github.com/eclipsesource/org.eclipse.papyrus-informationmodeling/tree/master/examples/org.eclipse.papyrus.information.modeling.examples/ProjectManagement)
Imports the ProjectManagement.uml
Found another bug on the package, which is a link to a package of DataTypes.uml,


We need more time to fix it.
Sorry for any inconvenience.


#3

The patch is ready.
Please update the software to latest patch build (20190430ae or later) to get the problem fixed.
Details about update to latest patch can be found at