Install_service failing


#1

Hi,

Firstly…LOVE YOUR PRODUCT

Secondly, in trying to install the floating license server as a service, I receive the following error:

D:\Program Files\VPServer\scripts>echo off
The vpserver.exe was not found…
The CATALINA_HOME environment variable is not defined correctly.
This environment variable is needed to run this program
Press any key to continue . . .

I tried to add CATALINA_HOME variable

D:\Program Files\VPServer\webserver\bin>set CATALINA_HOME
CATALINA_HOME=D:\Program Files\VPServer\webserver

but this didn’t fix the problem.

I am running 64 bit Win 2k12 R2. My installer was VP_Server_15_0_20180231_Win64.zip

Thanks in advance

cheers

Ruben


#2

Hi Ruben Morton,

Sorry for the issue that you are experiencing. The fix will be released soon, but it requires to re-install the server.
Instead of waiting for the fix, you can fix the problem by renaming tomcat8.exe to vpserver.exe and tomcat8w.exe to vpserverw.exe.

Sorry again for the inconvenience caused.


#3

Thanks heaps Kit. That worked, and was an excelent turn around time.

For any body else who is reading this,

when I right clicked the script, and “ran as administrator”, it failed. When I opened a command window, as administrator, in the scripts directory, and ran the install_service.bat there, it succeeded (and I had the CATALINA_HOME variable set. whether or not this was neccessary, I don’t know).

thanks

Ruben Morton