Installation issues on Ubuntu 11.10 64 bit

I’m trying to install Visual Paradigm community edition on my desktop:

-> Ubuntu 11.10 64 bit
-> Fresh install with latest updates
-> Installation started as follows: sudo sh

I get the following error:

Unpacking JRE …
Preparing JRE …
Starting Installer …
Could not display the GUI. This application needs access to an X Server.
If you have access there is probably an X library missing.

You can also run this application in console mode without
access to an X server by passing the argument -c

An error occurred:
java.lang.UnsatisfiedLinkError: /home/hbrems/Downloads/ wrong ELF class: ELFCLASS64
Error log: /tmp/install4jError7110364480227346500.log

I tried using the non GUI installation. Eclipse appears in the Unity menu but when I click the shortcut nothing happens.

I tried the alternative download which has no installer included. When I run the file …/bin/VP_Suite file (by double clicking on it and choosing run) nothing happens.

I have also validated the installation of libxp6 and my machine reports libxp6 is already the newest version.

Could anyone help out?

Hello hbrems,

As you are using a 64 bit linux, please download and install with the 64 bit installer. You can download the 64 bit installer from the following link, and this should solve your problem.

Best regards,

Thanks for the link. The application is running perfectly now.

Yeah, but what about x64 free version ?

Same installation file, just choose “Community Edition” during setup.