Installing VP standard 3 UML on MAC OS X (10.2.8)

My school has a school lisence for VP 3 for UML.
It works fine on various MS OS?s and on Linux…
But we cant get it to work on Mac OS X (build 10.2.8)
We hav installed the latest Java engine for OS X (1.4.1).
the install works and is ok.
But we cant seem to get the program started.

Hi Anders,

Have you tried running it from a terminal? The command is:
java -Xmx512 -classpath ./vpuml.jar;./vpumlresources.jar;./vpupdate.jar;./vp_help;./vpJavaHelp.jar RV

Hope this helps.


I tried to cut & paste the command into my terminal window and executed it.
but it didnt work…
This is what happend :

[admins-maskin:~] admin% java -Xmx512 -classpath ./vpuml.jar;./vpumlresources.jar;./vpupdate.jar;./vp_help;./vpJavaHelp.jar RV
Usage: java [-options] class [args…]
(to execute a class)
or java -jar [-options] jarfile [args…]
(to execute a jar file)

where options include:
-client to select the “client” VM
-server to select the “server” VM
-jvm is a synonym for the “client” VM [deprecated]
-hotspot is a synonym for the “client” VM [deprecated]
The default VM is client.

-cp -classpath <directories and zip/jar files separated by :>
              set search path for application classes and resources
              set a system property
              enable verbose output
-version      print product version and exit
-showversion  print product version and continue
-? -help      print this help message
-X            print help on non-standard options
              enable assertions
              disable assertions
-esa | -enablesystemassertions
              enable system assertions
-dsa | -disablesystemassertions
              disable system assertions

./vpumlresources.jar: Command not found.
./vpupdate.jar: Command not found.
./vp_help: Command not found.
./vpJavaHelp.jar: Command not found.

Have you had any problems with VP on Mac’s before?