Invalid configuration of SDE error

I get an Invalid configuration of SDE for Ecplise/IBM Webshpere

Invalid home Ecplise/IBM Webshpere home directory.

What can I do to fix this.

Excplise was installed, but not in c:\ecplise


Dear Tim,

Did you select the correct Eclipse home directory? It should be the directory where eclipse.exe is located.



What do you mean, selct the correct eclipse home directory …

Do you mean that where I install the software should be the same directory as eclipse.exe lis installed?

I did not see any other place that you choose this.



The installer will ask you where Eclipse is installed, so it can install the SDE plugins into Eclipse.

The eclipse home is where the eclipse.exe is found. So choose that directory when it asks for your Eclipse/IBM Websphere directory.

Hope this helps


I am trying to install VP_Suite_Windows_1_1_20050222.exe. It never asks where eclipse is installed. Of course, I may not be installing the right thing either.



Does it ask for other IDE’s such as JBuilder, Visual Studio or IntelliJ?


No it does not.

It has a window which asks what do you what to install.

The sequence is in the attached file.

Hi Tim,

I think you have an old version which has an old installer. Could you try downloading the latest version?



In the Select Visual Paradigm Product , The only selection is SDE for Eclipse/IBM Websphere Stdio, which is checked. The next window, Product configuration, I selected the community edition, The Install in existing Eclipse/IBM Websphere Studio is selected. Selecting Next causes the error.

A popup or dialog never appears asking where Ecplise is installed.

Of course, I installed eclipse in a non-standard place, but have tried on another machine and get the same error.

I have no idea what happened to the attachment in my previous post.

I’ll give it a shot.

I’ll get back to you with results.

Using VP Suite build 20050222 I get the same error.

The Product configuration window shows he SDE for Ecplispe …, it is selected,
The Install in existing Ecplise/… selection is selected, however, an Invalid Directory ? shows to the right of this. There appears to be nothing to change this to make it right.

Dear Tim,

Have you typed the correct Eclipse home directory near the “Install in existing Ecplise” field? You need to specify it because our installer will not detect this automatically. If the typed Eclipse home directory is invalid then the “Invalid Directory ?” error will disappear.




That was the trick.

I suggest that the text field for this be near that Install in exisintg radio button. It is not obvious that the text field is for that purpose but for the choice below.

Dear Tim

I agree that this would be quite confusing for users, we will try to add more description to the input fields that are not obvious for their purposes. Thank you very much for your suggestion.



i can not understand how i have to install .

  1. Welcome to the VP site1.1 setup
    press next
    2)I accept the agreement
    press next
  2. Select destinatin directory
    c:\Program Files\VP Suite 1.1
    press next
    3)Select the start Menu folder in which…
    Visula Paradigm
    press next
    4)select the file association…
    Click on Visula paradigm project(*.vpp)
    prss next
    5)select visual paradigm products
    Click on Visual Paradigm UML(VP-UML)
    smart Development environment2.1
    I click only sde for netBean/Sun ONE(sde-nb)

DB visul Architect 1.0
Click only on CBVA for NetBean/Sun ONE(DBVA-NB)
I clik only in this one.IT IS RIGHT???


Visual Paradigm for UML 4.1
edition??? Which one do i have to choice???

i try the Comunity(before i tryed the enterprise)

SDE for NetBean/Sun one 2.1
Clik on Install in existing NetBean/sun ONE

Directory C:\ProgramFile|javaSun

then DBVA for NetBean/sun one 1.0
clik on Install in existin NetBean/Sun ONE

directory C:\Program File|javaSun

Press next

i have the errors ???

"invalid configuration of SDE for NetBean/Sun One:
Invalid NetBean/Sun ONE home directory

Dear luca,

Are you sure the directory you typed “C:\Program File|javaSun” is the directory where you have an installed NetBeans/Sun ONE? If it is not, the installer will report the “Invalid NetBean/Sun ONE home directory” error.