JBuilder integration

I recently upgraded to VP-Pro 2.2 and integrated a VPUML project with my JBuilder project. The project has about 70K+ lines of code. When I try to update the model from JBuilder, both JBuilder and VPUML crash. Has anyone else experienced this problem? Any insight on where I can look to debug it?

Linux RedHat
JBuilder 9
VP-UML v2.2

I have tried testing the JBuilder integration with a project that has about 1 mb of source files and found no problem. Can you attach the log file “vp.log” which stored in the JBuilder/bin directory so that we can trace the cause of the problem?




I have just tested VP-UML Pro 2.2 (build 20031509e) with JBuilder 9 (Personal Edition) on a plain install of Red Hat 9.0. I did not encounter any problems with both VPUML-PRO and JBuilder crashing…

As antony has said, could you possibly attach the “vp.log” file which is stored in JBuilder’s /bin directory so we can look at the problem.

Thanks in advance.


Martyn and Antony,
Thank you for responding so quickly. I’m still running some tests and trying a couple different approaches (new VP project, existing VP project, etc…). I want to make sure I’ve exhausted all of my abilities before I waste your time. Give me one more day of testing.

 Also, I noticed that it is eating all of my memory when I do the reverse engineer.  I've only got 512MB on the box I'm testing on.  Could that have anything to do with it?

 I looked in the <JBuilder9>/bin directory and didn't see a vp.log file.  But I did find a few of them in my home directory.

Kevin E. Gaasch
Panhandle Plains Student Loan Center
Software Craftsman
Senior Programmer/Analyst
Work: 806.324.4100 x4215
Cell: 806.674.1523

Hello Martyn,
The project is about 70K lines of code when I reverse engineer it.

 I noticed something that might be a clue to what is wrong.  I ran a tail on the vp.log file while I opened VP-UML from JBuilder and noticed it is generating  an UnsatisfiedLinkException.  It appears to be looking for the I1, E1, and W1 lidraries.  I looked around and saw that there are I1, E1, W1, and jawt dlls in the JBuilder9/bin directory.  Shouldn't these be .so files instead of dlls?  I scanned through the VP-UML home directory and saw only dll files.  If these are in fact supposed to be so files, should I uninstall, re-download, and re-install?

So your CPU is relatively new…

Can I ask, how big is your project when you performe the code engineering? The code engineering does take up a fair bit of memory, however it is not necessarily VP-UML which is using it all. Infact, the IDE (run by the Java VM) invokes VP-UML from the same process. In most cases, it’s the IDE which is consuming the memory, however there is an old trick you can do for java based programs. Try minimising (both the IDE and VP-UML) to the taskbar and maximising it again. For some unknown reason, java likes to consume memory but not release it if it’s not being used. See if that solves your problem.

I’m not sure if it’s a better way, however I think you should use a pmap on the process which runs the IDE and VP-UML. Basically:

$ ps aux | grep java


$ pmap

It’s actually not a “continuous” check - it just checks it once off at the time of when the command was issued.


I noticed in the log files (attached to earlier post) has some NoClassDefFound exceptions. Could that be a problem with the profile I’m using? Is there something that I need to set in the profile?

I’m not positive on the CPU clockspeed. I’ll check that first thing in the morning. I know it’s not a Xeon, but it’s not very old either. It’s got 512MB of ram. I use top to watch the processes. I only open top to check the CPU/Mem usage then close it since top it’s is somewhat of a hog. I’m open to suggestions on better ways to monitor the resource usage.

Hi Kevin,

May I ask how you check how much memory the reverse engineer uses? Are you using:
pmap?, free? or top? What are the specs of your machine?


Hi Kevin,

The .dll files are actually not used in linux - the libraries are Windows platform specific and are copied unecessarily during the linux IDE integration. There is no need to uninstall/re-install.


So what do you think about the UnsatisfiedLinkError? I tailed the log again, this time just starting VP (not using JBuilder at all) and still got the UnsatisfiedLinkError. Any ideas?


Sorry about the late reply, the UnsatisfiedLinkError shouldn’t affect the running of VP-UML and/or JBuilder.