License probelm!


i downloaded the professional edition but on attempting to run it i got prompted for a license but didn’t recieve a license with it…

so i downloaded the community edition and this sent me a license by email but it can’t reverse engineer source code to UML …

does any one know how I could get a trial licence for the pro edition?

if any visual paradigm people are reading this could they contact me at with reference to this matter as i urgently need to generate UML diagrams from my java source code …!!

many thanks


I have exactly the same problem.

Also I was sent a key as the file vplicense.vplz. The license manager doesn’t recognize this as a valid license file.

Ditto Here.

I first downloaded VP For VS.Net community edition v1.1. The installation fails halfway with an error message " ".

I somehow found v1.0 of the same in a magazine CD. This installed fine, but the license file (sent to me by e-mail, vplicense.vplz) is not recognized by the license manager.

Hello support!! are u listening?

Hi Ankur,

The SDE1.1 key is in a different format and hence is not recogniseable by an SDE 1.0 product.

Hope this helps.


Actually, after installing v1.0, I opened Visual Studio.Net and started SDE. Immediately, The Activation Wizard started. Since we have a strict internet usage policy in force (No word called “email” in url), The wizard could not open this page. So, I copied the link it generated, and it looks like:

When I opened this link(on admin machine, which does not have above policy), I was taken to a page with all details filled up. When I clicked the submit(or something like that), it said the license will be e-mailed to me.

To cut the long story short, this is the file I received…and it doesn’t work.

So, Pls help me out

I get more worse situation:

I purchase the license and they did send it to me. However, the key they gave me is “Expired”. How can I pay $59.99 to buy an “Expired” key?

Who can help me on this! Is there anything wrong on my machine or my key?

Hi Shin-an Ju,

Thank you for raising this point. Our Sales team shall contact you shortly regarding this matter.


Hello Takai,

I am not authorised to release license keys, however I have notified the appropriate people regarding this issue. To save waiting for the key, try re-requesting the key as the server sometimes is under heavy load.

Thanks in advance.


Hello Martyn.
I downloaded and instaled sdecevs_20040414.msi.
I send request an activation key file through email, but I not received it.
Would you send me activation key file?

Hello Martyn.
Thanks by help, but I tried re-requesting the key many time and not received license keys yet. :((

I couldn’t open the .vplz file. help please.

I downloaded & installed the CE version for .Net 2003 today. (December 9, 2004) The license key file emailed to me is not recognised.
please help.

I have a similar problem as the previous poster…
The licence key manager doesn’t even start so I can import my licence file, I just get the error message “Your licence key is invalid, the application will exit”.
This happens with vpumlse as well as sdesevs :frowning:

Key Manager is not enabled under Model/Key Manager in Eclipse SDE 2.0 Plug in. I have the lisence key which i got thru mail. Kindly solve my issue. Update code command says that " Code Syncronization is not supported "


Here is the problem… it sounds like many others are having the same or a similar issue.

I am on a urgent project deadline, tried the software, and decided to update from the trial version to the modeler edition to be compliant with the commercial use requirements. So, I just purchased the Visual Paradigm for UML Modeler Edition and the license key provided (via my purchase confirmation email) causes the following error:

“License key(s) invalid the program will now close.”

When I look at the entry for this key in my key manager, it indicates that the key is valid and that it does not expire until 2-3-2010. This is the interim license key that is supposed to provide full functionality until they process my purchase and send me a permanent key. I attached the license key file that I am using in a request for help to technical support. I am still waiting… I just want what I paid for!

In the interim, if anyone is provided a solution, will you please contact me or reply to this post. Thanks very, very much.

Hi user,

Thanks for your post. As you mentioned you submitted a ticket to our technical support team, I believe you received reply from our support team. If you cannot find our email, please try to find it from trash/junk box.

Best regards,
Lilian Wong