MAC OS X: printing does not work


#1

Hi

I am using VP version 14.1 (build sp1_20170802) on MAC OS X 10.11.2

When I try to print one or more diagrams (that is, real print, open pdf, save as pdf, save as ps…), nothing happens.

Is there anything I should know/configure?

Thanks for your help

Regards

J-C


#2

We are very sorry about the problem you experienced.

However, we cannot reproduce the problem you mentioned.

Could you describe your problem a little bit more in details?

In the meantime, could you send us the log file for us further investigate?
You can export the log file through the “about dialog”.

Please send it to: support-team@visual-paradigm.com
and include the link to this post in the email.


#3

We have study your attached log file.
The log described Java unable to detect any print service.

We have found someone got similar problem
(https://bugs.openjdk.java.net/browse/JDK-8169620)
We suggest open “Printers & Scanners” in “System Preferences” before using Visual Paradigm to print.
Please kindly inform us if this workaround resolve your problem.


#4

Hello,

Thank for your proposed solution but that does not save the problem. I still get this exception in the log file.

[2017/08/18 17:27:28] [error] java.awt.print.PrinterException: No print service found.

Regards

J-C


#5

Could you tell us what printers you have installed to your Mac?
We guess it maybe caused by printer configuration. (e.g. internet printer, virtual printer)

Does any other application(s) able to print?
It maybe printer driver is not working.

Could you set another printer as default printer and give it a try?
It maybe only specific printer driver problem.


#6

It is a Brother MFC-L9550CDW (via Wifi)

I also tried with a MFC-7460DN without success (via cable to wifi router)

Other applications can print.

Thanks for your help.

J-C


#7

Could you test other Java application (e.g. Eclipse) able to print or not?
We guess it is Java related issue which only reproduce in very specific environment.


#8

It works with Eclipse. I can print java files.

I also installed the latest JDK.

J-C


#9

Sorry for the late reply.
I have study those information you provided.
Unfortunately, no hints from them.

Could you test attached Java program able to print or not?
Attached Java program is typical code of printing.
I want to confirm your environment able to print using typical code.
Suggest using JDK 1.8.0_121-b13 or newer.
TestPrint.java (1.4 KB)


#10

It prints ok when run from Eclipse.

I update to the latest java version:

java -version
java version "1.8.0_144"
Java™ SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot™ 64-Bit Server VM (build 25.144-b01, mixed mode)

and updated to VP 14.2

But it still does not print.


#11

Make sure you have the latest printer driver installed. Unlike on Windows, Mac OS X will automatically install the correct drivers for the printer you add the printer to the system. Update drivers through the normal software update process.
To make sure you have the latest printer driver installed, click on the Apple menu in the bar at the top of the screen, and select the App Store. Click the Updates tab and ensure that you have installed the latest software, especially the operating system or printer software.
If it’s an AirPrint-enabled printer and you’re printing through Apple’s AirPrint, then you may have to update the firmware with a firmware update provided by the manufacturer to fix the problem.
The cause of the printer failure is not receiving the print job is most likely due to lack of printer drivers on the computer, now you need to find and install the printer driver for your computer to fix the printer failure to receive the print job.


#12

I had the issues with printing to pdf as well but it was about 2 months ago. The thing is, however I was doing the export, all the object of the expectable pdf were printed on separate pages but not as the supposed to. I was fixing them with the third-party tool w9.pdffiller.com and it was working out well for me, right until the free trial has ended :slight_smile: Does any body know some workaround for this?