Not well-behaved in linux, KDE

I have been running applications from VP Suite 2.3, and have been experiencing a few annoying problems I’d like to share for in case they are not known.

1 - Sometimes dialogue boxes (like opening a specification edit box or a delete confirmation) go full-screen. Not a train-stopper, but a bit strange.
2 - Sometimes when VP applications crash and kills kicker (KDE taskbar), kdesktop, and sometimes even kwin (KDE window manager) in the process.
3 - Sometimes, when starting a VP application, it will resize all the other applications I have open to some random sizes.

These problems do not occur with any other Java applications I run, not any other non-java applications for that matter.

Case 2 is in itself not nice (apps should not crash from normal use), but killing my desktop and taskbar when it does so, is very bad behaviour. It might be some weakness in kicker, kdesktop and kwin, but since no other apps do this, I have to wonder. When VP crashes, these processes do not get terminated, but from then onwards, draw black on the screen, and do not respond from mouse or keyboard input. To get my desktop back, I have to re-start them.

Unfortunately, all of these problems occur sporadically and intermittently. I have not been able to reliably reproduce them, but in a day’s work with VP, each of these problems will happen several times.

When I run VP-UML in the fvwm environment rather than KDE, problem 3 goes away, and although it still crashes sometimes (case 2), it does not affect fvwm.

I mainly use VP-UML, drawing Class, Requirement, Use case and Activity Diagrams, but have found the same issues in the other applications included in the VP Suite.

I hoped these would be gone in 3.0, but alas, 3.0 does exactly the same.

For background info - I am running the x86_64 version of SuSE linux 10.1 and Sun’s Java.
My kernel version is
Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_09-b01)
Java HotSpot™ 64-Bit Server VM (build 1.5.0_09-b01, mixed mode)

Other than these annoyances, I am truly enjoying the product! Thank you so much for developing this!

Hello Elrin,

Thank you for sharing your experience with us. I guess there might be log file produced due to the crashing. Could you take a look at $vp-suite-install-dir/bin and see if there are files with name like hs_err_pid0000.log? If yes, could you post them here? Thanks a lot.

Best regards,

The only log file in that location is vp.log - I suspect there would be no error log due to running VP as a normal user per usual practice, not as root.
Perhaps I could suggest writing error logs in the workspace directory, since any user running VP should have write-access there.

Just in case it helps, here is the content of vp.log:

[Wed Dec 27 11:25:41 PST 2006] [message] [Wed Dec 27 11:25:39 PST 2006]: Start V
isual Paradigm for UML Community Edition [VP-UML CE]: 6.0 (20061218)
[Wed Dec 27 11:25:43 PST 2006] [message] Installation properties: /opt/VP_Suite3
[Wed Dec 27 11:27:01 PST 2006] [message] 27-Dec-2006 11:27:01 java.util.prefs.Fi
leSystemPreferences$2 run
INFO: Created user preferences directory.