Object reference not set to an instance of an object. when loading SDE in VS2008


I have just downloaded and installed VP-SDE for Visual Studio, selecting Visual Studio 2008 during the install.

But I have not yet managed to get the SDE open properly. Everytime the SDE opens it asks me whether I want to enable Remote Debugging and then whether I select Yes or No I get an error message stating:

Object reference not set to an instance of an object.

Then nothing happens. I have tried running from the Start Menu - Windows, Tools Menu from VS, right clicking on a project in VS and everytime I get the same message.
If i run it from the start menu, VS 2008 opens up (then error message) and then no new windows appear, the windows that I already have due to Visual Studio development are there, but there are no SDE windows there, and nothing appears. There is a progress bar at the bottom of the VS window that says:

Starting SDE-VS… with the bar moving all the time.

But nothing loads/nothing changes.

Is there anything I can do to get this to work?



Hello Andrew,

Thank you for your message. This problem should be fixed in our latest patch release. Can you download the latest patch build at the following link, and see is it working?


Look forward to hear from you.

Best regards,
Rain Wong