Out of Memory During Save

I was getting on well with the evaluation and had almost decided to buy the pro version until I tried to use it with a framework that consists of a large class hierarchy. Instant reverse worked fine and everything was great until I tried to save it…

Further investigation indicates it ran out of memory during the save- after allocating aver 500MB of virtual memory. Here is the bit from the log file:

I can save small models - upto this point I had played with upto about 50 classes.

As a further bit of information there is obviously an exception thrown at startup too :

[Thu Dec 30 22:15:27 GMT 2004]: Start Visual Paradigm for UML Professional Edition [VP-UML PE]: 4.0 (20041218b)
java.io.IOException: CreateProcess: jdk\bin\java -Xms64m -Xmx512m -cp “”;c:\progra~1\vpsuit~1.0\.install4j\i4jruntime.jar;c:\progra~1\vpsuit~1.0\launcher…\lib\vpplatform.jar;c:\progra~1\vpsuit~1.0\launcher…\lib\winpack.jar;c:\progra~1\vpsuit~1.0\launcher…\lib\jhall.jar;c:\progra~1\vpsuit~1.0\launcher…\lib\jniwrap.jar;c:\progra~1\vpsuit~1.0\launcher…\lib\vpJavaHelp.jar;c:\progra~1\vpsuit~1.0\launcher…\lib\openapi.jar;"" RV jdk error=2
at java.lang.Win32Process.create(Native Method)
at java.lang.Win32Process.(Unknown Source)
at java.lang.Runtime.execInternal(Native Method)
at java.lang.Runtime.exec(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at v.akg.i(:474)
at RV.main(:436)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.exe4j.runtime.WinLauncher.main(Unknown Source)

While I could increase the maximum memory allowed and also the physical memory on the PC that is not really an answer - VP-UML should not need to allocate massive amounts of memory to save the state that it is already maintaining!

Any solutions??


I’m having the exact same problem. I’m evaluating the product and I was very pleased until this poped up. Is there a work around?

Dear Paul,

Thank you for your message. Could you mind tell me what platform that you are using so that I can prepare a script file for you to run the application? Thanks!

Best regards,