Plugin integration with intellij idea

I downloaded VP for IntelliJ IDEA Professional, evalution edition. It all seems to be working, I can start the VP from the command line, but integratin with IDEA doesn’t work. I’m still getting message when starting IDEA :
“In order to complete the SDE-IJ instalation, please restart zour IntelliJ IDEA.” Well, I already restarted my computer :o) and it still doesn’t work. Any ideas?

I am having the same problem running Idea 4.0 under Mac OSX 10.3. Please help us!

Peter T. Brown wrote:

I am having the same problem running Idea 4.0 under Mac OSX
10.3. Please help us!

I am having the same problem under Windows XP.

How should I install this? I tried the windows installer, which failed, and the no_installer version; however, the installation instructions on the download page are always coming up blank for me. Do I just copy the sdeIJ directory under plugins to the IDEA plugins directory? What do I do with the bin directory?

I have tried to install version “sdepeij_20040224.exe”.

I have IntelliJ installed in the directory “C:\Program Files\idea1162_4.0”

Every time I run the SDE for IntelliJ setup, I get the message “Not a valid IntelliJ IDEA installation folder!”

Any workaround?

Also I’ve the same problem.
I’ve Idea 4.0 builds 1177 (from the early access site) and “sdeceij_20040224_no_install” and every time that I restart idea I get the prophetic message "In order complete to the SDE-IJ instalation, please restart your IntelliJ Idea."
Could someone give some explanations to all this?


Thanks a lot for sharing the tip, SDE-IJ “No Install” now works with the unzipped IDEA 4.0.1 (build #1178)!

OK, so it works if you replace relative …\plugins\sdeIJ\lib\vpsdeij.jar in the lax, or bat file or whatever config files there are to start your idea with fully quilified path : C:\your_idea\plugins\sdeIJ\lib\vpsdeij.jar. Well, it works 4 me at least :wink: .

I have gone through and tried all the solutions described here and in the message you have referenced. I still can’t get this working.

I’m on Mac OS X. I don’t have an idea.bat or idea.exe. I do have an IDEA native Mac application package, with an Info.plist in the package contents. I’ve tried to update the Classpath to directly include the VP jar file, but still get the same error message every time I restart IDEA.
Please see this post as well!

Still not working for me on Mac OS X. Has anyone got this working on a Mac that can give me specific advice on what I need to change to evaluate this product?

  • Tim

The last release SDE intelliJ version in MAC got a start up classpath problem.
To start up the SDE, please modify a file IDEA_HOME/Contents/Info.plist

Under this line:

Add the $APP_PACKAGE/plugins/sdeIJ/lib/vpsdeij.jar to become:

$APP_PACKAGE/lib/idea.jar:$APP_PACKAGE/plugins/sdeIJ/lib/vpsdeij.jar :/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home/lib/ext/jpda.jar:$APP_PACKAGE/lib/jdom.jar:$APP_PACKAGE/lib/log4j.jar

Sorry for the inconvenience, if have any problem please do not feel hesitate to contact me.