Recent update causing error loading jxbrowser


#1

Greetings,

I think this happened after 12.2 update. This worked back in June. When I start visual paradigm debugging session I now get a crash caused by jxbrowser.

Here is full message:


/usr/lib/jvm/java-7-jdk/bin/java -agentlib:jdwp=transport=dt_socket,address=127.0.0.1:46248,suspend=y,server=n -Dfile.encoding=US-ASCII -classpath /usr/lib/jvm/java-7-jdk/jre/lib/rt.jar:/usr/lib/jvm/java-7-jdk/jre/lib/javaws.jar:/usr/lib/jvm/java-7-jdk/jre/lib/charsets.jar:/usr/lib/jvm/java-7-jdk/jre/lib/jfxrt.jar:/usr/lib/jvm/java-7-jdk/jre/lib/jce.jar:/usr/lib/jvm/java-7-jdk/jre/lib/plugin.jar:/usr/lib/jvm/java-7-jdk/jre/lib/deploy.jar:/usr/lib/jvm/java-7-jdk/jre/lib/jsse.jar:/usr/lib/jvm/java-7-jdk/jre/lib/management-agent.jar:/usr/lib/jvm/java-7-jdk/jre/lib/jfr.jar:/usr/lib/jvm/java-7-jdk/jre/lib/resources.jar:/usr/lib/jvm/java-7-jdk/jre/lib/ext/dnsns.jar:/usr/lib/jvm/java-7-jdk/jre/lib/ext/sunec.jar:/usr/lib/jvm/java-7-jdk/jre/lib/ext/sunjce_provider.jar:/usr/lib/jvm/java-7-jdk/jre/lib/ext/localedata.jar:/usr/lib/jvm/java-7-jdk/jre/lib/ext/sunpkcs11.jar:/usr/lib/jvm/java-7-jdk/jre/lib/ext/zipfs.jar:/opt/VisualParadigm/12/plugins/sample.genflowofevents/classes:/opt/VisualParadigm/12/lib/vpplatform.jar:/opt/VisualParadigm/12/lib/jniwrap.jar:/opt/VisualParadigm/12/lib/winpack.jar:/opt/VisualParadigm/12/lib/openapi.jar:/opt/VisualParadigm/12/lib/lib01.jar:/opt/VisualParadigm/12/lib/lib02.jar:/opt/VisualParadigm/12/lib/lib03.jar:/opt/VisualParadigm/12/lib/lib04.jar:/opt/VisualParadigm/12/lib/lib05.jar:/opt/VisualParadigm/12/lib/lib06.jar:/opt/VisualParadigm/12/lib/lib07.jar:/opt/VisualParadigm/12/ormlib/orm.jar:/home/fai/apps/Intellij-Idea-14.1.5/lib/idea_rt.jar RV debug
Connected to the target VM, address: '127.0.0.1:46248', transport: 'socket'
[Sat Oct 10 12:07:22 EDT 2015]: Start Visual Paradigm Professional Edition [VP PE]: 12.2 (20151001)
Operating system: Linux 4.2.2-1-ARCH running on amd64
Java VM: 1.7.0_80 Java HotSpot(TM) 64-Bit Server VM, vendor 24.80-b11 Oracle Corporation
User: fai, language: en
Installation ID: c86320c0e897f53b6ce3d21433c4130b
Memory: current=361M, max=5356M
Refreshing language files in directory: /opt/VisualParadigm/12/bin/../UserLanguage
start startup getLicenseKey on 10-Oct-2015
getLicenseKey in local ...
getLicenseKey from server ...
finish startup getLicenseKey
getVerifiedLicenseKey: null; state=Evaluating
Installation properties: /opt/VisualParadigm/12/resources/vp/.vpsuite_installation.properties
Workspace: /home/fai/vpworkspace
UI mode: Classic
New Project: 40
Load application project: /home/fai/vpworkspace/.vpprefdata/.systemproject.vpp
New Project: 16
After open: : 124
 ---------- new TWClient ----------  
New Project: 636
Exception in thread "Thread-2" java.lang.NoClassDefFoundError: com/teamdev/jxbrowser/chromium/ProxyConfig
	at v.zii.af(:1534)
	at v.zii.r(:1283)
	at v.zwt.<init>(:4674)
	at v.aauf.b(:345)
	at v.aauf.a(:51)
	at v.aaug.run(:164)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: com.teamdev.jxbrowser.chromium.ProxyConfig
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

I tried looking through VP lib folder to see if its some obvious jar file I have to add to lib path but could not find any. What I am doing wrong? Thanks.


#2

Dear alextech,

Please make sure you have included lib01.jar to lib09.jar in your class path when running in debugging session. Feel free to contact me for any questions and wish you have a good day!

Best regards,
Rain Wong