Report generation not working


I have recently downloaded Visual Paradigm Community Version for use in my internship (advised by my teacher), and the generation of diagrams works very good. There is a problem with the report generation, however. When trying to generate a PDF file, the progress meter freezes. Sometimes it finishes, but then I got some sort of error: make sure the file is not opening. The preview also works sometimes, but when I try to go to the next page, I get an “Out of memory” error. I then get an error saying:
An exception occured when attempting to save the properties. File:
FonCache.ser (too many open files)

I run VP under Suse linux, KDE. I don’t have much experience with it, but I think this will give you the version:
KDE Version: 3.1.1
User: mklonen
Hostname: blaat
System: Linux
Release: 2.4.20:4GB
Machine: i686

Pentium 4 2,4ghz
1Gb memory

Can someone help?

Dear Michel,

The reason for the error message

Thank you, starting with the command line option did help making the preview function work, although I still get the: too many open fonts error when closing the preview. This is not much of a problem though… I started the program using this command line before you gave me the correct one: java -cp vpuml.jar:vpumlresources.jar RV jdk

But another thing I’ve noticed while browsing file dialog to specify the file I want to create for my report, is that I can only see my home folder, and no files and directories in it. I have full permissions for this folder.

Dear Michel,


Thanks! Doh! After all the fussing with the preview function I didn’t even try just generating the report 8)

Thanks for the help!