Resize Swim Lanes?


Sure I had this problem and resolved it in my earlier days but cannot find any reference to it now.

Problem simple enough to describe.

My swim lanes are horizontal.

Clicking on a swim lane makes all the grab handles appear as normal but the only ones that are black (active) are the mid lane ones which allow me to make the lane wider or narrower. The handles at the end are greyed out so I cannot change the length of the lane. This is irritating because the lanes are much longer than they need to be, so we’re displaying unnecessary empty space.

Can someone please explain (remind me of) the logic of this behaviour and how to get around it?

I should add the following bizarre behaviour.

In an effort to find a workaround, I placed a rectangle on the drawing, of the same dimensions I WANTED the swim lane to adopt, then selected both elements and use the alignment tools to make both elements the same width, following smallest. Instead of shrinking, the swim lane nearly doubled its length to the screed width!


Hi Harry,

I assume you are referring to Pool in Business Process Diagram, and it seems to have the auto stretch pool option turned on (which is the default). When a pool is set to auto stretch, you cannot adjust its length manually, it will auto expand to fit the width of the diagram (if Pool is horizontal).

To turn off auto stretch of a specific Pool, right-click it and select Presentation Options > Auto Stretch and ensure Off is selected.

To turn off auto stretch of all Pools in the Business Process Diagram, you can right-click on the diagram and select Presentation Options > Pool Display Options and then uncheck Auto Stretch Pools. This will disable auto stretching behavior of Pools whose option has been set to “Follow Diagram”.

Hope this could help,



well that was easy!
Sorted. Thanks