Reverse engineering citext columns on PostgreSQL


#1

Run reverse engineering on a PostgreSQL database and the citext columns ended up as integer 2147483647.
Any thoughts how I can fix this?

Using VP 15.0, PostgreSQL JDBC 4.2 Driver (https://jdbc.postgresql.org/download/postgresql-42.2.1.jar), on Mac OS X 10.13.3.

Here is a sample table

CREATE TABLE manufacturer
(
id integer NOT NULL,
manufacturerid citext COLLATE pg_catalog.“default”,
name citext COLLATE pg_catalog.“default” NOT NULL,
code citext COLLATE pg_catalog.“default”,
customerid integer NOT NULL,
createduser citext COLLATE pg_catalog.“default” NOT NULL,
modifieduser citext COLLATE pg_catalog.“default” NOT NULL,
createddate date NOT NULL DEFAULT (‘now’::text)::date,
modifieddate date NOT NULL DEFAULT (‘now’::text)::date,
CONSTRAINT pk_manufacturer PRIMARY KEY (id)
)

Gets reversed to:
|id|integer|0|true|false|false|
|manufacturerid|integer|2147483647|false|true|false|
|name|integer|2147483647|false|false|false|
|code|integer|2147483647|false|true|false|
|customerid|decimal|10|false|false|false|
|createduser|integer|2147483647|false|false|false|
|modifieduser|integer|2147483647|false|false|false|
|createddate|date|0|false|false|false|
|modifieddate|date|0|false|false|false|

Your input would be appreciated.
Thanks,
Ion


#2

Hi,

citext type is not officially supported, but it’ll be reversed as User type.
Please make sure you selected PostgreSQL as default in Database Configuration.
db

And enable Show Column User Type in Presentation Options.

Then you’ll get expected result.
erd


#3

Thanks for your input. The essence is setting PostgreSQL as default in Database Configuration, as soon as I did that it showed the columns properly.
Thanks again,
Ion


#4

You’re welcome and I am glad to hear that the problem was solved.