Round trip and svn

I’m experiencing problems with round trip in VP in a SVN environment. This is certainly due to a misunderstanding from me, but it is very annoying. I’m developing an application and I do a lot of round trip. When I update or commit the vp-uml in SVN via the teamwork menu, I get out of sync. (I can see that the “java round-trip” has disappeared in the tag “class repository”). So when I go on round-tripping, I run into problems. I can lose bodies of methods when I generate code or I get my methods twice when I reverse code. There must be a good practice, but I could not figure it out up to now.
What am I supposed to do when I commit/update a project?

Hi Ocaoca,

Thanks for your post. Do you mean after you run round-trip on project and then commit to server, the round-trip node in Class Repository disappeared when commit finished?

Could you please send me the vp.log file (inside VPSuite/bin folder) to take a look? Thanks in advance!

Best regards,
Lilian Wong

Thanks for your answer.

I could not figure out a pattern (update or commit). I lost my round-trip node when I update the model. I have just checked what happens while committing a project and I don’t actually lose the round-trip node.
I update the project more often than I commit it because I want to know the state of the overall project. So when I update, the round-trip node disappeas when the update is finished.
I send you vp.log, the last update was on June 12th

Hi Ocaoca,

Thanks for replying and the log file. Our engineers found a problem related to the round-trip path on teamwork project before, but the problem will result loss of round-trip path, but the “Java round-trip” node will not disappear from Class Repository.
Anyway, could you please try the latest build in the following link to see if your problem can be solved?

Hope this helps. I look forward to hearing your response.

Best regards,
Lilian Wong

Unfortunately, I work on linux (Build 20090608)

Please download the Linux version installer at:

Is there a Linux version of this patch?


Thanks, I’m testing it

Hi Ocaoca,

Thanks for replying. May I know can the patch solve your problem on Java round-trip node in Class Repository?

Best regards,
Lilian Wong

I have been testing this. Since I installed the patch, I haven’t lost the java round-trip node while committing the project. I still lose the node while updating the project.
I must say that I have not so many occurrences of commit (3 or 4 times). Before the patch, I could lose or not the node while committing. I have not been able figure out a pattern (apart from the update case, which seems to be systematic)

Hi Ocaoca,

Thanks for replying. May I know is the Java round-trip node disappears every time you update the project from server?

Best regards,
Lilian Wong

So far the java round-trip node has disappeared after each update from the server, which I do more often than committing

Hi Ocaoca,

Sorry for my late response. We tried with SVN that 2 users reverse code in different path with Java round-trip engineering, and one of the user update project, but we cannot repeat your problem (round-trip node disappears). In the following link you can see how we tried to repeat the problem:

Just to confirm: do all your team member import, commit, update project via Teamwork Client in the VP product?
And may I know which product are you using? Do any of your team member use IDE integration?

Best regards,
Lilian Wong

sorry for keeping you waiting.

It’s difficult to answer your questions. Most people of our team are experimenting problems like the one I described; that is using import, update, commit via teamwork client in VP. Most of us are on Linux, but not every one, which makes one of us claim the problem could be platform dependent. Nobody uses IDE integration.

I can add extra info in a update scenario:

  1. update the model (vp teamwork client)

  2. in a class diagram, I generate a class

  3. vp display a pop window, with a uncorrect path, which is the one corresponding to the vp teamwork path, but my source path is elsewhere.

  4. correct the path

  5. vp display a warning to overwrite an existing file.

  6. cancel

  7. I reverse the same class in the class diagram

  8. same as 3)

  9. I generate code ( I must change the ignore class because, it’s changed as well !!)

I last the body of my function, so
10) I roll back the change in an editor

11) I generate code and it works!!

All this is very impractical

Dear Ocaoca,
Sorry about the issue. We can repeat your issue in Linux with Windows client (Your team are right the problem is platform dependent). Our engineer fixed the issue and the fix is ready in latest patch. Please follow the procedure in below page to update to latest patch. Then the problem will be solved
* Update to latest patch is very easy. Your team no need to download and install anything. They just run update and select “Update to Latest Patch” (refer to above page).

Please pass above page to your team member to update to latest patch.

Finally sorry again the problem, we can do better to remove some waiting time. We will improve this workflow. Thank you for your patient about this issue.

Best regards,
Angus Chan

It seems to work after a few tests. I let know you if something still bothers me about teamwork. Nevertheless, I can’t help noticing that vpuml consumes 1.7 GB (The size of the project.vpp is 330 MB). It’s a bit too much as I do not consider upgrading my 4GB box, in which I also run eclipse and vmware among other application


Hi Oacoca,

Thanks for replying and we are glad that the patch works. Regarding to the memory usage, we use lazy-loading when open project. You are recommended to organize the model elements with Models/packages so that not all elements will be loaded when project is opened.

For organizing model elements with Model/packages, please refer to the following flash:
(you may need to turn the volume of speaker larger as the flash is in low volume)

Please feel free to contact me if there is any further question.

Best regards,
Lilian Wong